Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I have a D-Link wireless network card (WDA-2320). It's an Atheros 5212/5213 card. I am attempting to install Gentoo Linux 2008.0. I prefer to use the Minimal Install CD. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Kornfan71's Avatar
    Join Date
    Jul 2008
    Posts
    34

    Atheros 5212 woes


    Hi,
    I have a D-Link wireless network card (WDA-2320). It's an Atheros 5212/5213 card. I am attempting to install Gentoo Linux 2008.0. I prefer to use the Minimal Install CD. However, when I boot it up, it doesn't detect an ath0 or even a wlan0 interface, only eth0 and lo. I checked ifconfig and iwconfig, but nothing. However, the device is listed in lspci. So, following documentation, I checked "ls /lib/modules/`uname -r`/kernel/drivers/net" for an appropriate driver. I found nothing that seemed suitable for the card. So I'm not sure where to go from here, seeing as that computer gets no Internet in Gentoo. I also tried using the LiveCD, but no luck.

    Ideas?
    Thanks in advance!

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by Kornfan71 View Post
    Hi,
    I have a D-Link wireless network card (WDA-2320). It's an Atheros 5212/5213 card. I am attempting to install Gentoo Linux 2008.0. I prefer to use the Minimal Install CD. However, when I boot it up, it doesn't detect an ath0 or even a wlan0 interface, only eth0 and lo. I checked ifconfig and iwconfig, but nothing. However, the device is listed in lspci. So, following documentation, I checked "ls /lib/modules/`uname -r`/kernel/drivers/net" for an appropriate driver. I found nothing that seemed suitable for the card. So I'm not sure where to go from here, seeing as that computer gets no Internet in Gentoo. I also tried using the LiveCD, but no luck.

    Ideas?
    Thanks in advance!
    Welcome to the world of Gentoo.
    The way I get around this, I install Gentoo from a LiveCD or use an existing Linux installation. This way you can fart around with the games on the LiveCD or use networking while Gentoo compiles in the background. It takes a littie bit longer but I think it's worth it, rather than just watching Gentoo compile for hours at a time.
    Gentoo Linux Documentation -- The Gentoo Linux alternative installation method HOWTO
    This document may be a little outdated but I'm not sure. If you have any problems don't hesitate to ask.

    EDIT: Once you get the kernel installed, it has a built in driver called ath5k which means if your card is supported you will not need madwifi anymore. I'm almost positive your card is supported but if you want to be sure you can check here.
    About/ath5k - madwifi-project.org - Trac
    You can also download the module as mentioned in the above link.
    You can also get current ath5k code by downloading compat-wireless package from wireless.kernel.org.
    Last edited by MikeTbob; 06-07-2009 at 04:14 AM. Reason: See Edit
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Great advice MikeTBob, I just have one thing to add.

    I always use the System Rescue LiveCD that is based on Gentoo. It has pretty much everything you need to do a successful Gentoo install.

    I know it supports ath5k and wpasupplicant, because I used it on a pc that has that.

    Main Page - SystemRescueCd

    x86 and x86_64 are both on the same disk.

    You will have to set wpasupplicant up manually, but it isn't that hard. "wpasupplicant -h" will help you a lot.

    Linux User #376741
    Code is Poetry

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hiya gruven,

    Thanks for the tip, it makes perfect sense to me, so if I ever need to re-install I will use that. I usually always wind up manually installing almost all networking settings.

    Quote Originally Posted by gruven View Post
    Great advice MikeTBob, I just have one thing to add.

    I always use the System Rescue LiveCD that is based on Gentoo. It has pretty much everything you need to do a successful Gentoo install.

    I know it supports ath5k and wpasupplicant, because I used it on a pc that has that.

    Main Page - SystemRescueCd

    x86 and x86_64 are both on the same disk.

    You will have to set wpasupplicant up manually, but it isn't that hard. "wpasupplicant -h" will help you a lot.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined! Kornfan71's Avatar
    Join Date
    Jul 2008
    Posts
    34
    Well, for now, I'll be trying one of my oldest tricks: using my laptop as a network bridge. So far, it's working out OK. I'll leave it like that and then download the appropriate drivers later on! Thanks for the input, though. The SystemRescueCD looks like a tool that I'll start using!

  7. #6
    Just Joined! Kornfan71's Avatar
    Join Date
    Jul 2008
    Posts
    34

    Post

    So, I've made progress. I have built my kernel with support for ath5k, iwconfig returns wlan0 as an interface that's working, and I have wpa_supplicant installed. Unfortunately, when I run wpa_supplicant, it hangs and does nothing. My router is using WPA2-PSK with AES.

    Configuration:
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    ap_scan=1
    
    network={
        ssid="myssid"
        scan_ssid=1
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP
        psk="my_secret_psk"
    }
    Running "wpa_supplicant -dd -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf" shows that the handshake was completed and says "CTRL-EVENT-CONNECTED - Connection to (Router's MAC) completed...blah blah"
    At the bottom it says:
    Code:
    RSN: not in suitable state for pre-authentication
    EAPOL: startWhen --> 0
    EAPOL: Disable timer tick
    It then proceeds to do absolutely nothing.

    What is going on, but more importantly, how do I fix it??
    (If you need more info, I'd be more than happy to add it. Just say what you need.)

  8. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think what you need to do here is, after you run this command:
    wpa_supplicant -dd -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.con

    Provided everything is working right, and depending on that error you posted, which I have no idea about, all you need to do now is use dhcp to get the IP address and set DNS too.
    So launch the above command with an ampersand like this
    Code:
    wpa_supplicant -dd -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.con &
    This put the command in the background and returns the screen to you instead of forcing you to open a new terminal window to issue more commands. Next launch dhcp for wlan0, you might use dhclient or pump, whichever you have installed.
    Code:
    dhcpcd wlan0
    Try to ping google.
    Code:
     ping -c3 google.com
    What is the proto=rsn? I'm not familiar with that, but I think that is what caused that error.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •