Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Ok everything network wise was working during the whole install. System was going into reboot but locked up on "bringing eth0 down". When I restarted there was a message saying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1

    problem bringing up eth0


    Ok everything network wise was working during the whole install. System was going into reboot but locked up on "bringing eth0 down". When I restarted there was a message saying "ERROR: Problem starting needed services. "netmount" was not started." So I did some searching on the net, and read some about the rc-update command. I deleted netmount, then readded it as default. Same result. I then deleted netmount again and added it as boot. This time when the system rebooted there was no message but the two red !! were still there when it said "Bringing eth0 up via dhcp..." I can change netmount back to default instead of boot and the message shows up again. I really have no idea where to start besides searching more on the net for netmount, any input would be greatly appreciated! Thanks!

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    ifconfig eth0 up
    ???
    tried that yet?

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1
    I've got the same problem, ifconfig eth0 up doesn't work. Internet worked fine throughout the install. Now when I boot up it pauses at "bringing eth0 up via dhcp" (says something like that) for a while but doesn't work. When I run dhcpcd I get the same result.

    Right now I'm going to boot back up into Gentoo and see if I can figure it out.

    I'm pretty sure I configured the kernel correctly for my nic.

    If I figure it out I'll post back here.

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    UK
    Posts
    1
    Hi there

    I just had the same problem - Gentoo couldn't see my n/w card as I didn't emerge hotplug.

    I fixed it by going back to the livecd and :

    emerge hotplug
    rc-update add hotplug default

    I didn't change netmount at all.

    Also might be worth taking a look at lsmod and make sure the driver for your card is loaded - it might have some clues (obviously you'll need to do this in your own install - rather than the liveCD ).

  5. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Man...wtf is up with all you guys having this same problem?

    On a more serious note...you need to have hotplug emerged/running on the boot runlevel when using udev. Default may work, but I would put it on boot anyway. I know that at one point it didn't work on default (I think it depended on what else was in what runlevel).

    Also, I'll assume that you all are using udev, as devfsd is deprecated now.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #6
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    I'm having the same problem. I just did emerge -u world and finally got the updates to run. Last night I powered down the machine and disconnected everything so that I could move it to a new spot in my room, and now it says "netmount" not running and "sshd" not running.

  7. #7
    Just Joined!
    Join Date
    Oct 2004
    Location
    Somewhere
    Posts
    47
    Have you set your nic up?

  8. #8
    Just Joined!
    Join Date
    Oct 2004
    Posts
    13
    Ok everything network wise was working during the whole install. System was going into reboot but locked up on "bringing eth0 down". When I restarted there was a message saying "ERROR: Problem starting needed services. "netmount" was not started." So I did some searching on the net, and read some about the rc-update command. I deleted netmount, then readded it as default. Same result. I then deleted netmount again and added it as boot.
    Yeah, that's happens on some hardware during the shutdown when you do your reboot at the end of the install. In my case, I hit ENTER, it drops to a prompt, I type "reboot", it instantly reboots and boots up with the new settings you've entered in during the install for eth0 in conjunction with hotplug, etc. That netmount error happens if you haven't done the stuff below properly. Can't remember if it's when you don't add hotplug or if it's when you don't add modules into the kernel module autoloading file, but something is missing.

    Your install process should go something like:

    1. Bootup with LiveCD - if it's a laptop, type "gentoo dopcmcia" at the bootup prompt and hit ENTER.
    2. Run "net-setup eth0" and then "ifconfig -a" to test your settings are working. If you can connect with links2 to a download server, you have nic access for the rest of the installation process.
    3. After you build the kernel (genkernel all, or whatever you went with), "emerge hotplug".
    4. "rc-update add hotplug default" - this will autodetect the network card when you reboot after the installation, as well as lots of other stuff.
    5. A little later on in the install, you edit /etc/conf.d/net and setup your settings for eth0 and save it.
    6. "rc-update add net.eth0 default"
    7. If you are working on a laptop, type 'USE="-X" emerge pcmcia -cs', followed by "rc-update add pcmcia default", otherwise skip this step.
    8. Make sure in the process of doing the install you "cp -L /etc/resolv.conf /mnt/gentoo/etc/resolv.conf" or you won't have any DNS resolution.
    9. After the installation is done and you've rebooted, look for errors. If hotplug isn't detecting the NIC, you need to find out what the module name is for the NIC you're using (ie. 3x59x for 3Com 905x NICs) and add that module name to the end of the /etc/modules.autoload.d/kernel-2.4 file (or kernel-2.6, whatever you're using). If you're not sure what it is, watch the bootup process with the LiveCD and see what modules it autoloads and try adding those in. If you're using a laptop, you'll have to add in "yenta_socket" first, then your NIC module name. Module names have ".o" after them - don't put that part into the kernel-2.4/2.6 file though.

    Tip, if you get lots of complaints during startup from hotplug concerning missing modules (this happens during the pci autodetection section) then add the names of the missing modules to /etc/hotplug/blacklist at the bottom of the list (leave off the .o file extension) and you won't get any errors again. Usually it complains about a few things not being found, when they're not even on your system.

    Hope some of this helped.

  9. #9
    KFM
    KFM is offline
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    Do you still emerge hotplug when you don't use genkernel?

  10. #10
    Just Joined!
    Join Date
    Oct 2004
    Posts
    13
    The choice is yours. Hotplug is a separate entity from genkernel. Genkernel just automatically generates your kernel, regardless of whether you used gentoo sources (ie. "emerge gentoo-sources") or bland ol' favorites (ie. "emerge vanilla-sources"). Hotplug is handy because it automatically detects stuff when it boots up like sound cards, network cards, etc. - then if it complains about stuff that isn't in your computer, you just tell it not to in /etc/hotplug/blacklist and if it doesn't detect something, you can always force it by loading the module yourself, which supercedes anything hotplug does so it's not really harmful.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •