Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, Just a wee problem here that I was wondering if I could have some help with, been using linux for about two years now and last week made the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10

    [SOLVED] Wine directory exists on HD, terminal can access, dolphin cannot - Gentoo


    Hello,

    Just a wee problem here that I was wondering if I could have some help with, been using linux for about two years now and last week made the change from Ubuntu to Sabayon. Just emerged wine to 1.1.27 and started to install some apps using wine, and I needed to access the .wine directory in my root directory, but I cannot see it. Hidden files/folders are being shown, I can see the .wine directory in my /home/*username*/ folder, but this does not house the installations.
    If I run
    Code:
    locate .wine
    from the terminal, I get the following result:
    Code:
    /root/.wine/drive_c
    Hm.
    From the terminal I can cd into that directory, I can access the executable's I need to and run them, but I'm trying to access them using Dolphin. Can't see it. Using the address bar I type in the directory stated in the locate command, and I get told it does not exist. Hmmmm.
    Also, I have been creating a small bash script to easily open some applications wine is using that I need to use for my University work, however, I receive a 'Wine cannot find:' error. Weird thing is, directly from the terminal I can type
    Code:
    wine /root/.wine/drive_c/Program\ Files\
    or
    Code:
    wine /.wine/drive_c/Program\ Files
    and the app will start, but using that EXACT command in the script (I tried using sudo prefix but to no effect) it will not work.
    I tried to symlink which ls -n showed is valid, but I cannot cd into it and Dolphin displays it as a unknown filetype.
    I'm sure I'm just being a n00b and doing something simple wrong. My system is a Dell Vostro 1000 with AMD Sempron 2.00 ghz and 1 GB of ram, running Sabayon 4.2 with Wine 1.1.27.

    Thanks for any and all help,

    EN

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    I would strongly recommend against installing any applications with wine as root! Your system could be compromised due to any security flaw in the windows app. Wine is meant to be run as YOUR user only, this is why the applications are installed in your .wine folder. If you aren't running the windows installer as root or use sudo, they should be getting installed into your .wine folder.

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    Well my main problem here then is that I can't install the application as its an ISO and I can only mount as root.
    And not just that, I've had such extensive problems on making the installer work, now that it is installed, and that it does work, is there anything I can do to be able to get this script to work?
    I may have a slight whats going wrong, when in the terminal in order to start the application I use the code
    Code:
     wine /root/.wine/drive_c/Program\ Files/Microsoft\ Office/Office12/WINWORD.EXE
    and this works fine, but if I put this line into a script or application link then it shows as
    Code:
    wine /root/.wine/drive_c/Program Files/Microsoft Office/Office12/WINWORD.EXE
    , so is the problem that fact that it omits the spaces?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    Yes, you need to be root to mount an ISO, but not to read its contents as long as you mount it to a folder that anyone can access. The spaces need to be escaped in the script with the \.

  6. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    Thanks for the fast reply!

    I never even thought about mounting then wining as standard user, thanks for that tip! I will defiantly reinstall the application once this is resolved, but, and please correct me if I'm wrong, I'm guessing the same problem will still exist.
    Another problem is that I've only been able to get the application installer to run properly once, and I know its MS Office Word, but I have to use it for my course, other than that I'm fully OO.

    I just tried a couple of things, first of all to remove spaces in filepaths, error still occurs in script but is fine from terminal, I then used \ to indicate spaces, but I'm still getting the 'wine cannot locate' error.

    I'm going to remove winword and reinstall not as root as you suggested, if I can get the installer to work

    Are there any other possibilities of a work around on this? Also do you know why the symbolic link doesnt work?

    Thank you so much for your help!!

    MM

  7. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    10
    Problem solved, used gksudo in the script.

  8. #7
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Just for the record, both fuseiso and cdemu let you handle the mounting of ISO in user space, you don't need to be root for that. And I will not only advice to use wine as root, but also as your regular user.

    I use a separate account. That way, any malware that works under wine will not reach your files either.

  9. #8
    Just Joined!
    Join Date
    Sep 2009
    Posts
    1
    Thanks a lot. I think it's funny too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •