Find the answer to your Linux question:
Results 1 to 2 of 2
Hey. I'm currently trying to install Gentoo in VirtualBox OSE. I'm only doing it in a virtual machine so I can test it before I go to installing it on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35

    Trying to install Gentoo on VirtualBox OSE but fdisk command not found


    Hey.

    I'm currently trying to install Gentoo in VirtualBox OSE. I'm only doing it in a virtual machine so I can test it before I go to installing it on the hard drive.
    I'm following the wiki article and done everything it says.

    The problem is, I'm trying to use fdisk but it keeps saying command not found so I thought, possibly I need to get root so I tried it with su, su -, sudo and a bunch of other variants yet it says "Permission denied" after typing my password. The password is typed properly because I've typed it so many times and tried it so many times.

    But basically, I don't know why I'm unable to set up the partition scheme without fdisk.

    I also saw on another forum after searching through Google to try /sbin/fdsik -l but nor did that work.

    I set my user account and password okay...

    Is this something to do with Virtual Box OSE or have I missed something?

    Thanks.

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35
    Nevermind. I have figured it out now. Apparently, as an extra security precaution in Gentoo Linux, you have to add the user to the wheel group to be able to successfully log into root with su.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •