Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm a bit new to Linux and forums in general; but here's my predicament. I have a 15" G4 Powerbook, 1.33 GHz, standard issue, and I've been trying to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    1

    Gentoo on PowerBook G4 Not Working


    Hi, I'm a bit new to Linux and forums in general; but here's my predicament.

    I have a 15" G4 Powerbook, 1.33 GHz, standard issue, and I've been trying to put Gentoo on it. Whenever I pop in either the PPC Minimal CD or the PPC Universal CD, I hit return to boot the kernel, and the same error comes up:

    Invalid memory access at SRR0: 014072e0 SRR1: 00803030

    Then the computer boots up the Apple Firmware in terminal form. The PowerBook is essentially clean, nothing on it except Apple apps and a few pictures and documents. I was wondering if anyone of this forum had any idea of what's going on. Thank you.

  2. #2
    Linux Newbie ursusca's Avatar
    Join Date
    Dec 2008
    Location
    Toronto
    Posts
    116
    Hi,

    I think this is a hardware error.
    This is most likely either bad memory in your Powerbook, or a bad Logic Board.

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    1
    It's not a hardware issue. By default, a 64-bit kernel is chosen when you hit enter. When you are presented with the boot: prompt, hit Tab to see a list of kernels. The kernel for G5 processor will be the first one. I don't quite remember but I think the second or third is for a G4 processor. Just type the kernel name and then hit enter.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2011
    Location
    A backwoods mountain crevice in Colorado
    Posts
    1

    Cool "Invalid Memory Access at SRR0:" when using a LiveCD on a Mac

    Hello everyone, this may be late in the show but I wanted to add my experience with this error.

    I was trying to boot to a Gentoo Linux LiveCD and received the ubiquitous "Invalid memory access at SRR0: xxxxxxxxx SRR1: xxxxxxxxxx"

    After booting the LiveCD by pressing the "C" key at startup, the first prompt I got ended in boot:

    The Gentoo manual says to hit "Enter" at the boot: prompt. That ONLY works with G5 or newer models because, as I think imran1008 said previously, the 64-bit (G5) kernel loads by default. If I hit the "Tab" instead of enter, I only received one kernel in the list, which was the G5 kernel.

    So, I restarted and typed ppc32 at the boot: prompt and the LiveCD loaded as it should and worked great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •