Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hi folks , I tried with minimal cd (instalation) ,which i found cumbersome to do lots of things manually ... live Cd( good option ,it seems ) but i m ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    9

    best way to install gentoo...


    Hi folks ,

    I tried with minimal cd (instalation) ,which i found cumbersome to do lots of things
    manually ...

    live Cd( good option ,it seems ) but i m getting problem in gui (not gives the gui ,when booting ) and not even startx(fatal error 10) .

    even not detecting the eth0 too ..

    m i missing some steps or i need to do it all ,after installation , manually such as configuration files and emerge sort of things ..

    is thre any other method to do it without internet like : live dvd :

    plz. keep me out frm this puzzle ...

    tn'x
    dheeraj

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    9

    installation steps from live cd

    Hi folks ,
    i m installing gentoo using live cd (iso linux 3.09 2005-06-17)
    aftr booting frm cd ,i got gui having gui installer.that starts installation

    after stages disk partitioning ..and all it askes for display manager and x session ..
    that is confusing and after selecting gdm ..when i reboot it starts with blurr lines of text which ends after some time ..and it loads cli not the gui ..

    launching startx gives following error :









    (++) Using config file: "/etc/X11/xorg.conf "
    (EE) intel(0): detecting sill64
    (EE) Unable to Read from DV0I2C_E Slave 112.
    (EE) Unable to Read from DV0I2C_E Slave 236.
    (EE)Intel(0):ivch :unable to read register 0X00 from DVOI2C_B:04
    (EE) Unable to Read from DV0I2C_E Slave 112.
    (EE) Intel(0): tfp410 not deceted got vid FFFFFFFF:from DVOI2C_E Slave 112.
    (II) Module already built-in
    (EE) GARTInit :Unable to open /dev/agpgart(no such file or directory)

    (EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Couldn't allocate video memory

    Fatal server error:
    AddScreen/ScreenInit failed for driver 0

    XIO:fatal IO error 104(connection reset by peer) on X Server ":0.0"
    after 0 request (0 known procedure)with 0 event remaining .



    and even eth0 not deceted ...!!!

    what may be possibilities of such stuffs ..


    tnx
    Dheeraj

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    best way to install gentoo...
    Welcome to the forums!

    It's been a few years since I last installed Gentoo, but I always had success using the old text installer, whereas the liveCD never worked for me. I'd highly recommend having the installation handbook available either printed out on paper, or the online version, and make sure you follow each step exactly as given. If you are new to Linux, you might want to consider an alternative distribution, as Gentoo is not generally considered new user friendly, although lots of new users have installed it successfully.

    Perhaps some of the current Gentoo users that are members here will chime in with some specific help for the issues you describe above. Hope it all works out well for you.
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281
    The easiest way to install Gentoo, I found, is out of another Linux distribution already running on your machine. That way, you can do it bit by bit over as many days as you want. I did it out of Debian. And do use the command line; the whole process is much easier to understand that way. If you don't feel happy on the command line, I think a different distro would probably suit you better.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  6. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    Question for you

    Why would you try to install a 5 year old distro in any case.

  7. #6
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Quote Originally Posted by rhomp2002 View Post
    Why would you try to install a 5 year old distro in any case.
    It's not a 5 year old distro ... it's a 5 year old CD, since Gentoo is a rolling release update after
    Code:
    emerge -avuDN system
    emerge -avuDN world
    your good to go.

    Do the install using the handbook rather than any installer package. Any live CD or the minimal install CD will do for the install process. Personally I like to use a live CD for this, you will find quite a few threads with info example here.

    A key message is use the handbook to install

  8. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    With regard to Gentoo

    I realize i t is a rolling distro. However the liveCD of that time period was a disaster. I remember trying to install it and then reading the forum on Gentoo where the Gentoo experts were complaining about how bad it was. They were not able to get it to install either. In fact the consensus was that anyone wanting Gentoo should do it the old fashioned way.

  9. #8
    Just Joined!
    Join Date
    Feb 2010
    Posts
    9

    best way to install gentoo..

    Hey tht's fine..
    but with live cd the gui boot environment we get ..having two options
    one using gtk based installer and another one is command line installer..

    i ws using gtk based installer ..that is having problem in gui ,even not starting the startx.....

    shuld i use the command based installer...???

  10. #9
    Just Joined!
    Join Date
    Nov 2004
    Posts
    7
    I have been using 64bit Gentoo for five years now. In fact, I don't use any other OS or distro. I installed it just once in the past but my system is updated on a daily basis. It is simply not possible to have a more up-to-date linux installation than mine.

    Having said that, welcome to Gentoo!! You made the right decision

    I think the best way to install Gentoo nowadays is to use SystemRescue CD:
    www sysresccd org

    It is based on Gentoo, you have access to a GUI to perform the "manual and text" installation of Gentoo from within, and as a bonus you get a marvelous recovering CD if things go wrong in the future

    I recently installed Gentoo on a virtual machine and I used SystemRescue CD as the starting point, so I now what I'm talking about. It is a much better option than the official Gentoo installation disks. Just follow the official installation guides to the letter and you'll be on the right track.

    The most tricky part in a Gentoo installation is perhaps the kernel configuration if you want a customized instead of a generic one, because you have to know your hardware.

    Hope this info helps.

  11. #10
    Just Joined!
    Join Date
    Feb 2010
    Posts
    9
    tn'x 4 response but ..i m not doing things manually..
    the live cd haing gui installer which do the instalation by asking some steps to follow ...
    ....
    after instalation complete it shows window x server not
    configured correctly ..and switch to command mode ..
    i want to kno, after instalation ,is any thing required to do
    such as configur some files or antthing ...!!!!
    and why window x server not starting ..even i followd the all steps given in the installer..!!!!!!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •