Find the answer to your Linux question:
Results 1 to 2 of 2
Hi! Recently i've restructure my hda drive. Before: /dev/hda1 ext2 /boot -> boot partition (32 M) /dev/hd2 swap none -> swap partition (512M) /dev/hda3 ext3 / -> root partition (6,2GB) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    14

    ksmserver won't start up


    Hi!
    Recently i've restructure my hda drive.
    Before:
    /dev/hda1 ext2 /boot -> boot partition (32 M)
    /dev/hd2 swap none -> swap partition (512M)
    /dev/hda3 ext3 / -> root partition (6,2GB)
    rest of the disk (21Gb)
    now:
    /dev/hda1 ext2 /boot -> boot partition (32M)
    /dev/hda2 ntfs none -> windows XP (12Gb)
    /dev/hda3 ext3 / -> root partition (10Gb)
    /dev/hda4 -> extented partition
    /dev/hda5 swap none -> swap partition (600M)
    rest of the disk (6Gb)

    I deleted all partitions. I only backed up my root partition. So, i created the boot partition, installed windows on the 2nd partition, created the 3rd partition, copied all the backup files, created the 4th and the 5th partition, modified the fstab. I didn't know, how to set my bootpartition, so i run genkernel and it copied the initrd-2.6.7-gentoo-r11 and kernel-2.6.7-gentoo-r11 in my boot partition. So, after re-emerging grub and modifying the grub.conf, i rebooted my pc.
    I've only 3 accounts in my gentoo: oswaldo, katl and root.
    Now, when i try to log in as oswaldo, there pop a lot of windows up, saying (i dont remenber exactly) dcopserver not running, /home/oswaldo//.ke/share/config/kdeglobal not writable, then pop the wizard for kdeglobals up and then says: could not connect to ksmserver. Check your installation and then it goes to the login screen (once again).
    I can log in only as root. It pops nothing up.
    Whats the problem? What can i do?
    Thx in advance

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Posts
    14
    i fixed it!!!
    I gived as root:
    ls -l /home/oswaldo
    and oswaldo was owned by root, so i gived:
    chown -R oswaldo:users /home/oswaldo
    and boila!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •