Find the answer to your Linux question:
Results 1 to 2 of 2
I have been trying to set up ALSA on my gentoo system, kernel 2.6.34. I think I have an integrated nVidia High Definition sound card. I had ubuntu running with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    22

    [SOLVED] ALSA on gentoo


    I have been trying to set up ALSA on my gentoo system, kernel 2.6.34. I think I have an integrated nVidia High Definition sound card. I had ubuntu running with alsa working on this system.
    In my kernel I set
    Code:
    Device Drivers  --->
    <M> Sound card support  --->
    <M>   Advanced Linux Sound Architecture  --->
    <M>   OSS Mixer API
    <M>   OSS PCM (digital audio) API
    [*]     OSS PCM (digital audio) API - Include plugin system
    [*]   PCI sound devices  --->
    <M>   Intel HD Audio  --->
    [*]   Build hwdep interface for HD-audio driver
    [*]   Allow dynamic codec reconfiguration (EXPERIMENTAL)
    [*]   Support jack plugging notification via input layer
    alsaconf finds no drivers, and when I run "/etc/init.d/alsasound start" it returns with:
    Code:
     * Loading ALSA modules ...      [ ok ]           
     * Restoring Mixer Levels ...      [ok]
    lspci|grep -i audio returns with
    Code:
    00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
    And alsamixer says Card: HDA NVidia, but only has one bar to adjust the volume. What do I have to do to fix this?

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Did you solve this yet? Is the snd_hda_intel module loaded? Use the lsmod command to find out.
    Code:
    lsmod
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •