Find the answer to your Linux question:
Results 1 to 4 of 4
Keyboard work perfectly in console, but when i start x.org or xfce keyboard and mouse freezes i.e. even the capslock/numlock button won't turn on the light. I've tried sollutions from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    2

    [SOLVED] USB keyboard and mouse won't work under X.org


    Keyboard work perfectly in console, but when i start x.org or xfce keyboard and mouse freezes i.e. even the capslock/numlock button won't turn on the light.
    I've tried sollutions from this linuxforums.org/forum/gentoo-linux/145243-solved-gentoo-usb-mouse-keyboard-freeze-ind-gui.html thread but nothing seems to work.

    make.conf:

    # These settings were set by the catalyst build script that automatically
    # built this stage.
    # Please consult /usr/share/portage/config/make.conf.example for a more
    # detailed example.
    CFLAGS="-O2 -march=i686 -pipe"
    CXXFLAGS="${CFLAGS}"
    # WARNING: Changing your CHOST is not something that should be done lightly.
    # Please consult before changing.
    CHOST="i686-pc-linux-gnu"
    MAKEOPTS="-j3"
    USE="-gnome -kde -qt3 -qt4 X dbus hal startup-notification xscreensaver dvd alsa cdr"
    INPUT_DEVICES="evdev keyboard mouse"
    VIDEO_CARDS="nvidia"
    XFCE_PLUGINS="brightness menu trash"
    xorg.conf:

    Section "ServerLayout"
    Identifier "X.org Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/TTF/"
    FontPath "/usr/share/fonts/OTF"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/100dpi/"
    FontPath "/usr/share/fonts/75dpi/"
    EndSection

    Section "Module"
    Load "extmod"
    Load "record"
    Load "dbe"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mouse0"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    EndSection

    Section "Device"
    Identifier "Card0"
    Driver "nvidia"
    VendorName "nVidia Corporation"
    BoardName "G94 [GeForce 9600 GT]"
    BusID "PCI:4:0:0"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    SubSection "Display"
    Viewport 0 0
    Depth 1
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 4
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 8
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 15
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 16
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection
    Commenting InputDevice sections like so linuxforums.org/forum/gentoo-linux/145243-solved-gentoo-usb-mouse-keyboard-freeze-ind-gui.html#post689060 didn't do the trick.

    Result of
    Code:
    emerge -pv xorg-server
    These are the packages that would be merged, in order:

    Calculating dependencies ... done!
    [ebuild R ] x11-base/xorg-server-1.7.7-r1 USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib" 0 kB

    Total: 1 package (1 reinstall), Size of downloads: 0 kB

    * IMPORTANT: 3 news items need reading for repository 'gentoo'.
    * Use eselect news to read news items.

    Command
    Code:
    rc-status | grep hal
    don't show anything altough when I run
    Code:
    /etc/init.d/hald start
    it says that service is already started.

    Thanks beforehand.
    Last edited by kapuh; 12-13-2010 at 01:00 AM. Reason: problem solved

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    Did you emerge xorg-drivers?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Posts
    2
    Quote Originally Posted by MikeTbob View Post
    Hello and Welcome.
    Did you emerge xorg-drivers?
    You, sir win one free internets

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    So, it works now? Feel free to mark this thread as solved using the drop down menu at the top of this thread.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •