Find the answer to your Linux question:
Results 1 to 10 of 10
I was trying to install a jpeg library via ebuild and ran into a problem because the package required EAPI3. I did a sync and it told me that the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    5

    upgrading portage problem.


    I was trying to install a jpeg library via ebuild and ran into a problem because the package required EAPI3. I did a sync and it told me that the profile is not updated. I did a 'eselect profile set 1' which was the best match (default/linux/amd64/10.0). I was also informed that the new portage version should be installed. I then ran 'emerge portage' and it gave me this:


    Calculating dependencies... done!

    !!! All ebuilds that could satisfy "app-shells/bash-completion" have been masked.
    !!! One of the following masked packages is required to complete your request:
    - app-shells/bash-completion-1.2 (masked by: EAPI 3)

    The current version of portage supports EAPI '2'. You must upgrade to a
    newer version of portage before EAPI masked packages can be installed.


    I tried unmasking but it did not work because EAPI 3 was masking and you have to update portage first.
    I tried to install portage w/o dependencies 'emerge -avO portage' and it complaind about python being out of date. I could not get python updated because it also depends on app-shells/bash-completion.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome, Which version of portage?
    Try this one.
    Code:
    USE="-bash-completion" emerge -1 portage
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Posts
    5
    Thank you for trying to help.
    Here is what I got :


    Back1 ~ # USE="-bash-completion" emerge -1 portage

    * IMPORTANT: 6 news items need reading for repository 'gentoo'.
    * Use eselect news to read news items.


    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild N ] dev-libs/libffi-3.0.9 USE="-debug -static-libs -test"
    [ebuild U ] sys-devel/automake-wrapper-4 [3-r1]
    [ebuild N ] app-arch/xz-utils-4.999.9_beta USE="nls threads -static-libs"
    [ebuild NS ] sys-devel/automake-1.11.1 [1.9.6-r2, 1.10.2]
    [ebuild U ] sys-apps/sandbox-2.4 [1.2.18.1-r2] USE="(multilib%*)"
    [ebuild N ] virtual/libffi-0
    [ebuild U ] sys-devel/libtool-2.2.6b [1.5.26] USE="-test%"
    [ebuild U ] app-admin/eselect-1.2.11 [1.0.11-r1] USE="-bash-completion*"
    [uninstall ] app-admin/eselect-news-20080320
    [blocks b ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.11)
    [ebuild N ] app-admin/eselect-python-20100321
    [ebuild NS ] dev-lang/python-2.6.6-r1 [2.5.2-r7] USE="berkdb gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst"
    [ebuild U ] sys-apps/portage-2.1.9.25 [2.1.6.13] USE="(ipc%*) -python3%"
    *** Portage will stop merging at this point and reload itself,
    then resume the merge.
    [blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking app-arch/xz-utils-4.999.9_beta)
    [blocks B ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.6.6-r1)

    * Error: The above package list contains packages which cannot be
    * installed at the same time on the same system.

    ('installed', '/', 'app-arch/lzma-utils-4.32.7', 'nomerge') pulled in by
    app-arch/lzma-utils required by ('ebuild', '/', 'sys-devel/libtool-2.2.6b', 'merge')

    ('ebuild', '/', 'app-arch/xz-utils-4.999.9_beta', 'merge') pulled in by
    app-arch/xz-utils required by ('ebuild', '/', 'sys-apps/sandbox-2.4', 'merge')

    ('ebuild', '/', 'dev-lang/python-2.6.6-r1', 'merge') pulled in by
    dev-lang/python:2.6 required by ('ebuild', '/', 'sys-apps/portage-2.1.9.25', 'merge')


  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'm thinking you might need to update Python first.
    Code:
    python-updater
    This might take awhile so grab some coffee and a book.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    Jan 2011
    Posts
    5
    It did not do anything and it took less than a second.
    running: USE="-bash-completion" emerge -1 portage
    still produces the same errors.

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    What do you mean it didn't do anything? No error or anything? That error will not change until we can figure out the problem. You might have to unmerge or mask some things until you can get the latest portage installed.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    Jan 2011
    Posts
    5
    I entered the command and it returned as if I put a comment on the line.
    No errors. no text at all.
    I also tried to upgrade portage to a lower version like so:
    Back1 ~ # emerge -p '<portage-2.1.6.7'
    >>> --pretend disables --ask... removing --ask from options.

    These are the packages that would be merged, in order:

    Calculating dependencies... done!

    emerge: there are no ebuilds to satisfy "<sys-apps/portage-2.1.6.7".

    and when I tried:
    Back1 ~ # emerge -p '=portage-2.1.6.7'
    >>> --pretend disables --ask... removing --ask from options.

    These are the packages that would be merged, in order:

    Calculating dependencies... done!

    !!! All ebuilds that could satisfy "=sys-apps/portage-2.1.6.7" have been masked.
    !!! One of the following masked packages is required to complete your request:
    - sys-apps/portage-2.1.6.7 (masked by: profile)

    For more information, see the MASKED PACKAGES section in the emerge
    man page or refer to the Gentoo Handbook.


    Any ideas?

  8. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Can you try to update the entire system first? This command, unless it fails, should update all packages on your machine.
    Code:
    emerge -avuDN system world
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  9. #9
    Just Joined!
    Join Date
    Jan 2011
    Posts
    5
    Thank you for trying to help. We tried and it did not work. We gave up on the idea to upgrade and decided to rebuild the machine.
    Thanx

  10. #10
    Just Joined!
    Join Date
    May 2011
    Posts
    1
    Thanks for clues

    But i did it in this way

    emerge older version of portage to update python to 2.6 version using command

    Code:
    USE="-bash-completion" emerge -1 portage-2.1.8.3
    there was 3 packages that blocks updating so i unmerged those,
    in my case those ware eselect-news, lzma-utils and libtool

    then update of portage -2.1.8.3 was sucessful
    next
    Code:
    python-updater
    then emerge latest portage version
    Code:
    emerge portage
    and update world to refresh system
    Code:
    emerge -Du world

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •