Find the answer to your Linux question:
Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 31 to 40 of 44
Originally Posted by nessonic Code: /dev/hda1 on /mnt/hda1 type ext2 (rw) /dev/hda3 on /mnt/hda3 type ext3 (rw) For the second: lrwxrwxrwx 1 root root 1 Mar 1 00:12 boot -> ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045

    Quote Originally Posted by nessonic View Post
    Code:
    /dev/hda1 on /mnt/hda1 type ext2 (rw)
    /dev/hda3 on /mnt/hda3 type ext3 (rw)
    For the second:
    lrwxrwxrwx 1 root root 1 Mar 1 00:12 boot -> .
    -rw-r--r-- 1 root root 408688 Mar 1 12:08 gentoosrc2636
    drwxr-xr-x 2 root root 1024 Mar 1 22:52 grub
    drwx------ 2 root root 12288 Mar 1 06:04 lost+found

    I'm downloading the iso for knoppix now; copying over the 3rd command is too much.
    edit: The following are going to be the same results, but within Knoppix (through root terminal, the normal terminal gave me issues such as now allowing those commands)

    Code:
    /dev/sda1 on /mnt/hda1 type ext2 (rw,relatime,errors=continue)
    /dev/sda3 on /mnt/hda3 type ext3 (rw,relatime,errors=continue,barrier=0,data=writeback)
    and now the third:
    Code:
    drwxr-xr-x  2 root root      4096 Mar  1 22:47 bin
    drwxr-xr-x  2 root root      4096 Mar  1 06:06 boot
    drwxr-xr-x 10 root root     36864 Feb 22 15:09 dev
    drwxr-xr-x 32 root root      4096 Mar  1 22:52 etc
    drwxr-xr-x  2 root root      4096 Feb 22 13:01 home
    OK so looks like you have hda1 as boot partition and hda3 as root partition. As you can see from your output the first CD you booted from is using hda but the second is using sda device identification. You have the symlink for boot so try

    Code:
    title Gentoo Linux - sda
    root (hd0,0)
    kernel /boot/gentoosrc2636 root=/dev/sda3
    # could have used kernel /gentoosrc2636 root=/dev/sda3
    
    title Gentoo Linux - hda
    root (hd0,0)
    kernel /boot/gentoosrc2636 root=/dev/hda3
    # could have used kernel /gentoosrc2636 root=/dev/hda3
    One of the above should work for system boot. Suggest you restart with Knoppix CD and try chroot in, check etc/fstab contents match filesystem type and designation to match either sda or hda grub entries above. Also check kernel has support for ext3 file system and hard drive built in (not a module).

    Post back commands used and errors received if chroot fails.

  2. #32
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44
    For clarification, my hdd is IDE if that matters or explains why I used hda.

    I chrooted in and edited the fstab file to have "sdax" instead of "hdax." Same bootup issue as before, though I expected that.

    The file I need to edit is menu.1st, right? Which is located on sda1. However, I am unable to edit that, and if I try chrooting into it with sudo chroot /mnt/sda1 then it says
    chroot: failed to run command '/bin/bash' : No such file or directory

  3. #33
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    OK can you boot from the knoppix CD and try
    Code:
    sudo -s
    mkdir /mnt/sda3
    mount /dev/sda3 /mnt/sda3
    mount /dev/sda1 /mnt/sda3/boot
    mount -t proc none /mnt/sda3/proc
    mount -o bind /dev /mnt/sda3/dev
    chroot /mnt/sda3 /bin/bash
    if chroot fails then check output of
    Code:
    ls /mnt/sda3/bin/bash -l

  4. $spacer_open
    $spacer_close
  5. #34
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    At this point I would just like to congratulate you on sticking with this, you will be able to thank yourself later because you are learning things even though you haven't had any kind of "smashing success", but I think it's coming and you're on the right path. Being a Gentoo user will put you through your paces that's for sure. Keep up the good work.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #35
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44
    MikeTbob, thanks for the compliment. I hope after this install I may even go through it again later on, or just try it on another dell I have to get more familiar with linux (and computers in general).

    Which by the way, Jonathan if you're able to tell me whatever you just told me to do so I can understand what happened, that'd be good. It worked, in the sense that I got a bit further, however, the error message that got spit out doesn't sound good:

    Mounting proc at /proc ... [ok]
    Mountain sysfs at /sys ... [ok]
    Mounting /dev ... [ok] (all of these are ok until the WARNING)
    Starting udevd ...
    Populating /dev with existing devices through uevents ...
    Waiting for uevents to bro processed ...
    Mounting devpts at /dev/pts ...
    Checking root filesystem ...
    WARNING: bad format on line 30 of /etc/fstab
    fsck.ext3: No such file or directory while trying to open /dev/ROOT
    /dev/ROOT:
    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

    *Filesystem couldn't be fixed
    Give root password for maintenance
    (or type Control-D to continue):

    Also, entering the root password I made at the very beginning of the install doesn't work. Control D reboots to the same issue.

  7. #36
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    WARNING: bad format on line 30 of /etc/fstab
    Check your /etc/fstab file carefully or post it's contents here.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #37
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44
    Line 30 was a blank line, I removed the gap (it was between the sda3 line and the cdrom line) and the error is no longer there. Everything else in the error is the same, however.

  9. #38
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Quote Originally Posted by nessonic View Post
    Which by the way, Jonathan if you're able to tell me whatever you just told me to do so I can understand what happened, that'd be good.
    man command_you_use should provide information. I wanted you to boot from the knoppix CD as you are able to post output ... and we know from your previous posts knoppix is using sda rather than hda reference for your hard drive.

    I'll try to give a brief overview of what each command does (or at least what I understand each command does ) ... they are all just aimed at chroot into the system you have already installed on sda3.

    Code:
    sudo -s
    will start a root shell so you don't need to put sudo at the beginning of the other lines ... sudo allows you to execute commands as another user (default to root if no user specified).

    Code:
    mkdir /mnt/sda3
    just creates a folder /mnt/sda3 for that live session we need to create a folder to mount the partition to.

    Code:
    mount /dev/sda3 /mnt/sda3
    everything is a file or folder ... this command mounts the filesystem on partition /dev/sda3 and makes the contents available at the location /mnt/sda3.

    The boot partition and temporary file systems proc and dev should be available for the chroot environment (proc and dev are required each time you chroot - boot is optional), the next three commands take care of that ...
    Code:
    mount /dev/sda1 /mnt/sda3/boot
    mount -t proc none /mnt/sda3/proc
    mount -o bind /dev /mnt/sda3/dev
    That should have set everything up you need to chroot ... so
    Code:
    chroot /mnt/sda3 /bin/bash
    should put you in the new environment you built during the install process.
    Have a look on the Gentoo wiki here for more information on chroot from a live CD

    btw I suggest you post the fstab contents and let us know whether using sda or hda grub entry got you further through the boot process ...

  10. #39
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44
    Weird, on this boot with the livecd...all the g's were gone. So it was entoosrc2636, rub instead of grub, etc.

    Here's fstab:


    # /etc/fstab: static file system information.
    #
    # noatime turns off atimes for increased performance (atimes normally aren't
    # needed; notail increases performance of ReiserFS (at the expense of storage
    # efficiency). It's safe to drop the noatime options if you want and to
    # switch between notail / tail freely.
    #
    # The root filesystem should have a pass number of either 0 or 1.
    # All other filesystems should have a pass number of 0 or greater than 1.
    #
    # See the manpage fstab(5) for more information.
    #

    # <fs> <mountpoint> <type> <opts> <dump/pass>

    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/BOOT /boot ext2 noauto,noatime 1 2
    /dev/ROOT / ext3 noatime 0 1
    /dev/SWAP none swap sw 0 0
    /dev/cdrom /mnt/cdrom auto noauto,ro 0 0
    #/dev/fd0 /mnt/floppy auto noauto 0 0

    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    # use almost no memory if not populated with files)
    /dev/sda1 /boot ext2 defaults,noatime 1 2
    /dev/sda2 none swap sw 0 0
    /dev/sda3 / ext3 noatime 0 1

    /dev/cdrom /mnt/cdrom auto noauto,user 0 0

    proc /proc proc defaults 0 0
    shm /dev/shm tmpfs nodev,nosuid,noexec 0 0

  11. #40
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Code:
    # /etc/fstab: static file system information.
    #
    # noatime turns off atimes for increased performance (atimes normally aren't 
    # needed; notail increases performance of ReiserFS (at the expense of storage 
    # efficiency).  It's safe to drop the noatime options if you want and to 
    # switch between notail / tail freely.
    #
    # The root filesystem should have a pass number of either 0 or 1.
    # All other filesystems should have a pass number of 0 or greater than 1.
    #
    # See the manpage fstab(5) for more information.
    #
    
    # <fs>			<mountpoint>	<type>		<opts>		<dump/pass>
    
    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    #/dev/BOOT		/boot		ext2		noauto,noatime	1 2
    #/dev/ROOT		/		ext3		noatime		0 1
    #/dev/SWAP		none		swap		sw		0 0
    #/dev/cdrom		/mnt/cdrom	auto		noauto,ro	0 0
    #/dev/fd0		/mnt/floppy	auto		noauto		0 0
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for 
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files)
    
    ### change /dev/sda to /dev/hda if kernel uses hda rather than sda reference
    ### eg change /dev/sda1 to /dev/hda1 and /dev/sda2 to /dev/hda2 and /dev/sda3 to /dev/hda3
    /dev/sda1		/boot		ext2		defaults,noatime	1 2
    /dev/sda2		none		swap		sw			0 0
    /dev/sda3		/		ext3		noatime			0 1
    	
    /dev/cdrom		/mnt/cdrom	auto		noauto,user		0 0
    
    proc			/proc		proc		defaults		0 0
    shm			/dev/shm	tmpfs		nodev,nosuid,noexec	0 0
    /dev/BOOT /dev/ROOT /dev/SWAP and /dev/cdrom lines should be commented out - they should start with a #

    The above fstab should work if you are using the grub entry
    Code:
    title Gentoo Linux - sda
    root (hd0,0)
    kernel /boot/gentoosrc2636 root=/dev/sda3
    # could have used kernel /gentoosrc2636 root=/dev/sda3
    But you need to change sda to hda in fstab if you are using the grub entry
    Code:
    title Gentoo Linux - hda
    root (hd0,0)
    kernel /boot/gentoosrc2636 root=/dev/hda3
    # could have used kernel /gentoosrc2636 root=/dev/hda3
    (chroot in and use nano /boot/grub/grub.cfg to update grub as required)

Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •