Find the answer to your Linux question:
Results 1 to 3 of 3
I successfully emerged KDE after everything here : http://www.linuxforums.org/forum/gen...-internet.html Looking around, it looks like I have to type startx to ge that running, then add kdm to rc-update and setting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44

    [SOLVED] Cannot start KDE


    I successfully emerged KDE after everything here : http://www.linuxforums.org/forum/gen...-internet.html

    Looking around, it looks like I have to type startx to ge that running, then add kdm to rc-update and setting it as the display manager in conf.d as described here: KDE - Gentoo Linux Wiki

    For one, startx gives this error:

    Code:
    xauth: file /root/ .serverauth.3831 does not exist
    
    /etc/X11/xinit/xserverrc: line 2: /usr/bin/X: No such file or directory
    /etc/X11/xinit/xserverrc: line 2: exec: /usr/bin/X: cannot execute: No such file or directory
    xinit: giving up
    xinit unable to connect to X server: Connection refused
    xinit: server error
    Next, rc-update gives this:

    * rc-update: '/etc/init.d/xdm' not found; aborting

    If kde emerged successfully...what's the next step to getting it even running?

  2. #2
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Code:
    emerge xorg-x11
    Emerging KDE for some reason does not pull all the dependencies in for xorg to start.

    Also, that documentation looks to be a little out of date, so add
    Code:
    polkit, consolekit
    to your USE flags. Then, you will want to
    Code:
    emerge -uDN world
    and start consolekit as a service
    Code:
    /etc/init.d/cosolekit start
    rc-update add consolekit default
    I know some of the newer KDE releases require that.

    Also, you don't need hal anymore (on the newest KDE, not sure which version is in stable). hal is deprecated.

    Linux User #376741
    Code is Poetry

  3. #3
    Just Joined!
    Join Date
    Feb 2011
    Posts
    44
    Thank you, that worked! Now to just work out getting used to KDE and my CPU issues, as well as installing all my programs.

    I'll mark this as solved, hopefully it can help someone who gets stuck on the documentation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •