Find the answer to your Linux question:
Results 1 to 2 of 2
I am on my third attempt at installing gentoo 2.6.36-r8. This time i ran into a new error. I cannot emerge any packages. I searched web with no luck. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156

    [SOLVED] Lost emerge after new install


    I am on my third attempt at installing gentoo 2.6.36-r8. This time i ran into a new error. I cannot emerge any packages. I searched web with no luck. I am on another computer so I can not copy and paste. But here is the first line:

    open('/etc/portage/make.conf' . 'r'): [Errno 20] Not a directory: 'etc/portage/make.conf

    Traceback (most recent call last):
    File "/usr/bing/emerge, line 43, in <module>
    retval = emerge_main ()

    this is repeated for 6 other File entries. the last line is

    10error: [Errno 201 Not a directory: '/etc/portage/make.conf

    I am still in run level 3, I get the same results from normal user or root Frank
    Last edited by frank56; 04-16-2011 at 01:23 PM. Reason: found error in post

  2. #2
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    I am not dead sure, what the problem was, but, I strongly suspect an incorrect or incomplete linen in

    cp -L /etc/resolv.conf /mnt/gentoo/etc/

    I think his error disabled my previous good internet connection. I am not sure but for emerge to work, an internet connecition is needed. I did not see an edit button on my post, so thats why I am posting a reply to myself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •