Find the answer to your Linux question:
Results 1 to 3 of 3
my /etc/fstab : Code: /dev/md0 /boot ext2 noauto,noatime 1 2 /dev/md1 none swap sw 0 0 /dev/md2 / ext4 noatime 0 1 shm /dev/shm tmpfs nodev,nosuid,noexec 0 0 Most of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    2

    Angry Partitions are mounted wrong


    my /etc/fstab :


    Code:
    /dev/md0    /boot   ext2    noauto,noatime  1 2
    /dev/md1   none     swap    sw              0 0
    /dev/md2    /         ext4     noatime         0 1
    shm  /dev/shm    tmpfs       nodev,nosuid,noexec    0 0

    Most of time it was ok , but from last time updates it changed and now looks like that :

    Code:
    Filesystem           1K-blocks      Used Available Use% Mounted on
    rootfs               238158544 117808536 108252264  53% /
    /dev/root            238158544 117808536 108252264  53% /
    rc-svcdir                 1024       116       908  12% /lib64/rc/init.d
    udev                     10240       200     10040   2% /dev
    shm                    2024624         0   2024624   0% /dev/shm
    shm                    2024624         0   2024624   0% /dev/shm
    also it says that /dev/root is mounted as ext3 and my partition is ext4

    boot log says :
    Code:
    [    1.237277]  md2: unknown partition table
    [    1.260137] EXT2-fs (md2): error: couldn't mount because of unsupported optional features (240)
    [    1.313171] EXT4-fs (md2): mounted filesystem with ordered data mode. Opts: (null)
    [    1.313361] VFS: Mounted root (ext3 filesystem) readonly on device 9:2.
    How can I fix this , so it will all mount properly as earlier ?
    Also I have kernel 2.6.38-gentoo-r6 x86_64 version.

  2. #2
    Just Joined!
    Join Date
    Mar 2011
    Posts
    67
    have you tried running fsck on it? sometimes if a file system gets damaged from improper shutdown it will be mounted as readonly.

    you should boot off a livecd when you run fsck. and the command should look like this:
    Code:
    fsck -y /dev/ROOT
    replace ROOT with the actual device file your root partition gets mounted as. the -y handle pretty much says yes to all repairs, which can sometimes be considered dangerous. but if you leave the -y off you will be forced to manually approve each file system repair which can take a long time.

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    2
    problem solved by adding

    Code:
    rootfs=ext4
    to grub kernel command line

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •