Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
# app-office/openoffice -> app-office/libreoffice It's just a comment so that you will know openoffice has been or will be replaced by libreoffice. Anything that starts with a bang (#) is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864

    # app-office/openoffice -> app-office/libreoffice
    It's just a comment so that you will know openoffice has been or will be replaced by libreoffice.
    Anything that starts with a bang (#) is just comments and is ignored by the system......as for the other question...the reason I don't understand why openoffice is being pulled in, is because it's been obsoleted and it should not get pulled in. Why should you need something that is going to be masked in 30 days?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  2. #12
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    Mike, I finally got python-updater to update python. I was able to emerge avahi and network-manager. I don't think I did the most efficient way, it took about 12 hours to configure 50 packages, the longest being open office. Should I have emerged Libre office? Also what allowed to python update was adding an [>] to the following:

    For more information, see the MASKED PACKAGES section in the emerge
    man page or refer to the Gentoo Handbook.

    # Tomáš Chvátal <scarabeus@gentoo.org> (27 Jul 2011)
    # Old replaced packages. Will be removed in 30 days.
    # aoffipp-ce/openoffice -> app-office/libreoffice
    # app-office/openoffice-bin -> app-office/libreoffice-bin
    # app-text/wpd2sxw -> app-text/wpd2odt
    app-office/openoffice <-----------to that line I just changed to >app-office/openoffice
    app-office/openoffice-bin
    app-text/wpd2sxw

    That action set an "invalid atom" that remains, but allowed python-updater to run. What would be the correct setting to eliminate invalid atom message? So far I just get a warning, without being kept from running programs? I still have some tweeking to do on Network Manager. Thanks Mike and everyone for the help. Frank

  3. #13
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Glad things are getting sorted for you, keep pounding on it and sooner or later it will submit to you.
    I think the invalid atom should be changed to >=app-office/openoffice.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    Quote Originally Posted by MikeTbob View Post
    Glad things are getting sorted for you, keep pounding on it and sooner or later it will submit to you.
    I think the invalid atom should be changed to >=app-office/openoffice.
    That did not work either Mike. I wonder If I should just use equal sign, or is the atom consist of the 3 programs as in:

    app-office/openoffice <-----------to that line I just changed to >app-office/openoffice
    app-office/openoffice-bin
    app-text/wpd2sxw

    ?

  6. #15
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I have that >= in my package.mask file and I don't get that invalid atom error....check your package.use and or make.conf files also. Another thing, I am not using /etc/portage/profiles/package.mask I'm just using /etc/portage/package.mask and so on.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #16
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    Quote Originally Posted by MikeTbob View Post
    I have that >= in my package.mask file and I don't get that invalid atom error....check your package.use and or make.conf files also. Another thing, I am not using /etc/portage/profiles/package.mask I'm just using /etc/portage/package.mask and so on.
    Thanks Mike I noted your differences. On my box, I solved it with :
    =app-office/openoffice-3.2.1-r

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •