Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    kernel panic not syncing vfs unable to mount root fs on unknown-block

    Hey, I know this isn't a first for this. I've googled it, and it came up with a lot of similar posts, but unfortunately, none of them have helped. I know it's not bad blocks because I've used fsck.ext4, it did repair the log, but that was it. My partition table is as follows:

    sda1 /boot ext2
    sda2 swap
    sda3 /

    I've tried playing with grub.conf, but nothing changes. I've check the, and it's all good. I tried reinstalling grub, still nothing. I've checked my fstab just to make sure things were okay, and again, nothing. So I'm at wits end. Maybe my grub.conf is configured incorrectly, but I followed the Gentoo docs, so I can't find any error. Here is my grub.conf:

    default 0
    timeout 30
    title Gentoo Linux 2.6.39-gentoo-r3
    root (hd0,0)
    kernel /boot/kernel-2.6.39-gentoo-r3 root=/dev/sda3
    title Gentoo Linux 2.6.39-gentoo-r3 (rescue)
    root (hd0,0)
    kernel /boot/kernel-2.6.39-gentoo-r3 root=/dev/sda3 init=/bin/bb
    It's very similar to the one that was supplied in the package, I only modified it to fit the kernel version, other than that, it's identical to the one found in the Gentoo installation guide docs.

    I really don't know what's going on. It's not really important because it's just in a VM, but I would really like to learn more about Linux, and I feel building a Gentoo install would benefit me a lot. Thanks.

  2. #2
    I'm assuming you are using ext4 as your root partition since you ran fsck.ext4 on it.
    Did you compile ext4 support into your kernel?

    Also, it would be great if you could post your fstab anyways, just in case you have a small typo lurking or maybe additional info that could shed insight.

    And finally, it sounds like this is a fresh build, no? If not, what major changes did you make just before it stopped mounting the root partition?

    Your grub.conf looks ok to me assuming that is what you named your kernel and grub is installed on the first partition of the first hard disk.
    Last edited by bleedingsamurai; 09-21-2011 at 02:09 AM. Reason: hit post too soon, added information

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts