Find the answer to your Linux question:
Results 1 to 4 of 4
I have been trying to follow this tutorial on grub: http://www.linuxforums.org/forum/lin...lems-grub.html I have a dell gx270 with ide hard drive. I checked the kernel to see if ata_piix were enabled, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156

    New Install reboots to grub only prompt, no errors, splash screen ok


    I have been trying to follow this tutorial on grub:

    http://www.linuxforums.org/forum/lin...lems-grub.html

    I have a dell gx270 with ide hard drive. I checked the kernel to see if ata_piix were enabled, and they were., for my ide controller. When, as tutorial suggests, to kernel /boot/kernel-3.0.6-gentoo, It finds my kernel. When I hit enter, I get kernel panic. I am not sure what to try next.

    Can I assume, my hardware is not causing the problem?

    I will continue, researching this, while I wait for a reply.
    Also, I have a nice blue splash screen. I don't know if that means, my hardware is ok.

    I should explain there are panic related errors which I will try to copy from the panic screen.:

    VFS: Cannot open root device "null)" or unknown-block(3,3)
    Please append a correct "root= boot option; here are the available
    partitions:
    0800 199382240 sda driver:sd
    ( it continues with 4 more)

    Then Kernel panic - not syncing: VFS Unable to mount root fs on unknown block(3,3)
    Pid 1, comm: swapper not tained 3.0.6-gentoo #1

    That is only part of what is on the screen, I don't know of any other way of saving complete . I plan to web search some of the errors.
    Last edited by frank56; 12-24-2011 at 12:18 AM.

  2. #2
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    I solved the kernel panic part. After installing same kernel on another hard drive, I concluded, it may be something in the hard drive. Somehow I had deleted partitions 1 and two. I cant explain how I could still get a splash screen. I did a slow format with a windows xp disk, and since fdisk would not allow partitioning for some reason, I used Parted. I may still be having a hard drive problem. The other drive was easy to setup. Right now I can boot from grub screen by typing kernel /boot/kernel-3-.0.6-gentoo. than boot. And I get a normal boot. But when I reboot its back to the grub prompt screen. grub> <---like that.

    If someone can tell me if there are in errors in my grub.conf

    Code:
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    
    #title Gentoo Linux 3.0.6-gentoo
    root (hd0,0)
    kernel /boot/kernel-3.0.6-gentoo root=/dev/sda3
    
    
    #title Gento Linux 3.0.6-gentoo (rescue)
    root (hd0,0)
    kernel /boot/kernel-3.0.6-gentoo root=/dev/sda3 init=/bin/bb
    
    
    
    
    
    #initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo
    
    
    # vim:ft=conf:
    (chroot) sysresccd boot # ls
    boot  grub  kernel-3.0.6  lost+found
    Code:
    Also here is my Fstab , and some one let me know if I am doing this bb code right. :-)
    
    dev/sda1               /boot           ext2    defaults,noatime        1 2
    /dev/sda3               /               ext3            noatime         0 1
    /dev/SWAP               none            swap            sw              0 0
    /dev/cdrom              /mnt/cdrom      auto            noauto,ro       0 0
    /dev/fd0                /mnt/floppy     auto            noauto          0 0
    
    proc                    /proc           proc            defaults        0 0
    
    shm                     /dev/shm        tmps        nodev,nosuid,noexec 0 0
    Last edited by frank56; 12-25-2011 at 03:41 AM. Reason: More info

  3. #3
    Just Joined!
    Join Date
    Mar 2011
    Posts
    68
    Try removing the hash on the title lines, that comments them out.
    Maybe grub just doesn't know what to do since it doesn't have any options to give you, XP

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    Quote Originally Posted by bleedingsamurai View Post
    Try removing the hash on the title lines, that comments them out.
    Maybe grub just doesn't know what to do since it doesn't have any options to give you, XP
    Thanks Bleedingsamarai. Indeed that was one of the many errors I ran into, after doing several starts and having to start over from the beginning, but it sure did me good, and IMO, practice, practice, practice, nothing wrong with that. I got to the point I can changroot repeating the steps, almost by memory. That was because I had to go back and forth to make changes. The other error of more than two error was in fstab, as I can see now on my post here. Where I should have had, /dev/sda2, i had the word "SWAP".
    Last edited by frank56; 12-26-2011 at 09:44 AM. Reason: error in post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •