Find the answer to your Linux question:
Results 1 to 3 of 3
I tried package mask and package use, but can't seem to get rid of block package error message. Here is my error message: Code: [ebuild U ] sys-apps/sysvinit-2.88-r3 [2.88-r2] [blocks ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156

    Unable to progress beyone blocked packages.


    I tried package mask and package use, but can't seem to get rid of block package error message. Here is my error message:

    Code:
    [ebuild     U  ] sys-apps/sysvinit-2.88-r3 [2.88-r2]
    [blocks b      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)
    [ebuild     U  ] sys-power/pm-utils-1.4.1-r2 [1.4.1] USE="debug*" 
    [blocks B      ] app-mobilephone/obex-data-server ("app-mobilephone/obex-data-server" is blocking app-mobilephone/obexd-0.43-r1, app-mobilephone/obexd-0.44)
    [blocks B      ] app-mobilephone/obexd[server] ("app-mobilephone/obexd[server]" is blocking app-mobilephone/obex-data-server-0.4.5)
    
     * Error: The above package list contains packages which cannot be
     * installed at the same time on the same system.
    
      (app-mobilephone/obex-data-server-0.4.5::gentoo, ebuild scheduled for merge) pulled in by
        >=app-mobilephone/obex-data-server-0.4.5 required by (gnome-base/gvfs-1.10.1::gentoo, ebuild scheduled for merge)
    
      (app-mobilephone/obexd-0.44::gentoo, ebuild scheduled for merge) pulled in by
        app-mobilephone/obexd required by @selected
        app-mobilephone/obexd required by (net-wireless/gnome-bluetooth-3.2.1::gentoo, ebuild scheduled for merge)
    
    
    For more information about Blocked Packages, please refer to the following
    section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
    
    http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
    and here is my /etc/portage/package.use

    Code:
    x11-base/xorg-server udev
    gnome-base/gnome-session branding
    
    # net-misc/curl -nss gnutls ares
    >=sys-apps/pciutils-3.1.8 -zlib
    >=net-dns/avahi-0.6.30-r2 gtk3
    net-wireless/wpa_supplicant qt4
    net-print/cups ppds
    net-fs/samba readline cups pam
    net-fs/samba swat
    
    >=dev-ruby/json-1.6.3 ruby_targets_ruby19
    >=dev-ruby/racc-1.4.7 ruby_targets_ruby19
    >=dev-ruby/hoe-2.12.4 ruby_targets_ruby19
    >=dev-ruby/rake-0.9.2.2 ruby_targets_ruby19 -doc
    >=dev-ruby/rdoc-3.12 ruby_targets_ruby19
    dev-lang/php truetype exif
    >=dev-vcs/git-1.7.8.3 webdav curl
    >=dev-ruby/rubygems-1.8.11 ruby_targets_ruby19
    
    =dev-vcs/git-1.7.8.3 webdav curl
    >=dev-ruby/rubygems-1.8.11 ruby_targets_ruby19
    >=dev-ruby/rdoc-3.12 -doc
    >=dev-ruby/racc-1.4.7 -doc
    sci-libs/hdf5 threads -cxx -fortran
    >=dev-python/jinja-2.6 -doc
    >=app-mobilephone/obex-data-server-0.4.5 -server
    And here is my /etc/portage/package.mask

    Code:
    >=net-misc/networkmanager-0.8.997
    >=app-office/libreoffice-3.4.99.2
    =app-mobilephone/obexd-0.43-r1

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Code:
    emerge -pv app-mobilephone/obexd
    Post the output please. You may need to remove the server use flag from make.conf
    EDIT: https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers
    Last edited by MikeTbob; 01-20-2012 at 01:34 AM. Reason: added link
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156
    Quote Originally Posted by MikeTbob View Post
    Code:
    emerge -pv app-mobilephone/obexd
    Post the output please. You may need to remove the server use flag from make.conf
    EDIT: https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers
    Thanks Mike, removing the server flag from /etc/make.conf did the trick. Problem solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •