Find the answer to your Linux question:
Results 1 to 1 of 1
I have been able to solve similar problems to this one before, but I am stuck on this one. I am not sure what keyword changes I am being asked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2009
    Posts
    156

    The following keyword changes are necessary to proceed net-print/cups


    I have been able to solve similar problems to this one before, but I am stuck on this one. I am not sure what keyword changes I am being asked ot make. Here is the message:

    Code:
    k # emerge -av net-print/cups-bjnp
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild  N    *] net-print/cups-bjnp-1.0  121 kB
    
    Total: 1 package (1 new), Size of downloads: 121 kB
    
    The following keyword changes are necessary to proceed:
    #required by net-print/cups-bjnp (argument)
    =net-print/cups-bjnp-1.0 **
    
    NOTE: The --autounmask-keep-masks option will prevent emerge
          from creating package.unmask or ** keyword changes.
    
    Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
    Note the asterik following ebuild N is red.

    Solved. The two asteriks held the key to the problem. As in :=net-print/cups-bjnp-1.0 ** . I think they were the "key word". I did this in my /etc/make.conf
    ACCEPT_KEYWORDS="**" That solved the problem, it was just a guess on my part, I don't know if that was the correct solution though.
    Last edited by frank56; 02-04-2012 at 01:55 AM. Reason: Solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •