I reinstalled a system yesterday, wheres I also copied back some (but not that many or for which I know very "critical") config files. I have installed a bunch of packages but suddenly I recieved this, and find no (good) way around it:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
<dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)

(dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.35:2 required by (gnome-base/gvfs-1.16.3::gentoo, ebuild scheduled for merge)
Then I checked what it would look like if with only glib,
shiva# emerge -vp dev-libs/glib

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-libs/glib-2.32.4-r1:2 USE="static-libs -debug (-fam) (-selinux) -systemtap {-test} -utils -xattr" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-libs/glib:2

(dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge) conflicts with
<dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)
I think this looks really strange, and was wondering if something a did wrong during the installation may have caused this, and of course what to do about it.

I just ran a 'emerge --update --newuse --deep world && emerge --depclean' and was now going to install xfce4-meta. I tried to install xfce4-meta before aswell, but with the same message.