Find the answer to your Linux question:
Results 1 to 2 of 2
I'm interested in increasing the resolution of my command line (ie before I start X). I used to know how on the "old" grub, using framebuffers and stuff. But I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    5

    CLI Resolution


    I'm interested in increasing the resolution of my command line (ie before I start X). I used to know how on the "old" grub, using framebuffers and stuff. But I'm brand new to using grub2, which has a different configuration method. I've also heard that most new graphics cards have framebuffer support built in, and enabling it in software will cause problems (My card is 4 years old...).

    Can anyone explain how you'd go about changing your command line resolution in the "modern" era? Or at least point me in the right direction? Thanks.

  2. #2
    Just Joined!
    Join Date
    Apr 2014
    Location
    Dublin
    Posts
    9
    hi
    assuming you have /boot on a separate partition the main config file you can find in /boot/grub/grub.cfg, but this file is a product of the actual config files located in /etc directory i.e.
    /etc/grub.d and /etc/default/grub

    To see the section related to the screen resolution you open /boot/grub/grub.cfg:
    if loadfont /share/grub/unicode.pf2 ; then
    set gfxmode=640x480
    load_video

    The above section should be a product of /etc/default/grub config file - see section:
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    What is weird, the above line is hashed, so I wonder how come it is un-hashed in grub.cfg file?

    Anyway, I guess youd unhush the above and try to set the resolution compatibile to your monitor and what happens.

    ok, I actually found a tutorial and checked it myself - it was on ubuntu forum.
    1. Edit /etc/grub.d/00_header file.
    2. Find in there section as below:
    if loadfont `make_system_path_relative_to_its_root "${GRUB_FONT_PATH}"` ; then
    set gfxmode=${GRUB_GFXMODE}

    Just right below that line enter the below line:
    set gfxpayload=keep

    3. Now update GRUB2 so that /boot/grub/grub.cfg file will be re-generated again (you may want to make a copy of previous version, just in case... .):
    #update-grub

    4. Reboot your machine and check if it is something you aimed for.

    Myself, I havent noticed any noticeable difference, so I got back to previous settings, but I assume my GRUB correctly sees screen resolution on my laptop, so only the GRUB list of available systems are in 640x480 (or perhaps 800x600) resolution, but then it goes to higher resolution displaying the whole boot process like that.

    I hope the above will be some point of reference anyway.
    good luck and let us know if you solved - and how - this issue.
    Last edited by breadfan; 04-19-2014 at 04:37 PM. Reason: correcting and updating

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •