Find the answer to your Linux question:
Results 1 to 10 of 10
After installing KDE, how am I able to view my other drives. I have 2 IDE drives and 3 SCSI drives on my system the only one I can see ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102

    device issue


    After installing KDE, how am I able to view my other drives. I have 2 IDE drives and 3 SCSI drives on my system the only one I can see is the for the Gentoo system. When I type in fdisk -l I can see all my drives. When I go to Konqueror and type in devices:/ I dont see all the drives. What am I to do?
    Registered user #372186 -- http://counter.li.org

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Code:
    fdisk -l
    will show you the device found, this doesnt meen they are mounted. To be able to see the data, you need this operation... If you can post the output of this, we'll gladly help...

    Code:
    as root
    fdsik -l
    cat /etc/fstab
    cat /etc/mtab
    Thanks
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    Here is everything

    tux root # fdisk -l

    Disk /dev/hda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 1275 10241406 c W95 FAT32 (LBA)
    /dev/hda2 * 1276 1280 40162+ 83 Linux
    /dev/hda3 1281 1465 1486012+ 82 Linux swap / Solaris
    /dev/hda4 1466 4865 27310500 83 Linux

    Disk /dev/hdb: 20.4 GB, 20416757760 bytes
    16 heads, 63 sectors/track, 39560 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes

    Device Boot Start End Blocks Id System
    /dev/hdb1 * 1 39555 19935688+ 7 HPFS/NTFS

    Disk /dev/sda: 18.3 GB, 18351959040 bytes
    255 heads, 63 sectors/track, 2231 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 2230 17912443+ c W95 FAT32 (LBA)

    Disk /dev/sdb: 18.3 GB, 18351959040 bytes
    255 heads, 63 sectors/track, 2231 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 2231 17920476 c W95 FAT32 (LBA)

    Disk /dev/sdc: 36.7 GB, 36778545152 bytes
    255 heads, 63 sectors/track, 4471 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 4470 35905243+ 7 HPFS/NTFS
    tux root # cat /etc/fstab
    # /etc/fstab: static file system information.
    # $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03:38 azarah Exp $
    #
    # noatime turns off atimes for increased performance (atimes normally aren't
    # needed; notail increases performance of ReiserFS (at the expense of storage
    # efficiency). It's safe to drop the noatime options if you want and to
    # switch between notail and tail freely.

    # <fs> <mountpoint> <type> <opts> <dump/pass>

    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda2 /boot ext2 defaults,noatime 1 2
    /dev/hda4 / ext3 noatime 0 1
    /dev/hda3 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
    /dev/fd0 /mnt/floppy auto noauto 0 0

    # NOTE: The next line is critical for boot!
    none /proc proc defaults 0 0

    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    # use almost no memory if not populated with files)
    # Adding the following line to /etc/fstab should take care of this:

    none /dev/shm tmpfs nodev,nosuid,noexec 0 0

    tux root # cat /etc/mtab
    /dev/hda4 / ext3 rw,noatime 0 0
    devfs /dev devfs rw 0 0
    none /proc proc rw 0 0
    none /sys sysfs rw 0 0
    none /dev/pts devpts rw 0 0
    /dev/hda2 /boot ext2 rw,noatime 0 0
    none /dev/shm tmpfs rw,noexec,nosuid,nodev 0 0
    none /proc/bus/usb usbfs rw 0 0
    I thought this was the way to go. But being new. I didnt want to chance it. Help is better than nothing.
    Registered user #372186 -- http://counter.li.org

  4. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    You need to mount the drives. To mount your first scsi drive in /mnt:

    Code:
    mount /dev/sda1 /mnt
    If you want them all to be mounted all the time, you'll need to add appropriate entries in /etc/fstab, as well as choosing places (directories) to mount them to. Check the man pages for fstab and mount to learn about this.

  5. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Hey mate ok.. I've reed you file, and sure sure have a lot of drive in there

    Here's what the fstab should look like to mount all devices...
    Code:
    /dev/hda2 /boot ext2 defaults,noatime 1 2 
    /dev/hda4 / ext3 noatime 0 1 
    /dev/hda3 none swap sw 0 0 
    /dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0 
    /dev/fd0 /mnt/floppy auto noauto 0 0 
    #here's the HD that were not in there initially
    /dev/hdb1 /mnt/HD_1 ntfs rw,umask=0 0 0
    /dev/sda1 /mnt/SCSI_1 vfat iocharset=iso8859-1,codepage=850,rw,umask=0 0 0
    /dev/sdb1 /mnt/SCSI_2 vfat iocharset=iso8859-1,codepage=850,rw,umask=0 0 0
    /dev/sdc1 /mnt/SCSI_3 vfat iocharset=iso8859-1,codepage=850,rw,umask=0 0 0
    #end's here's
    none /proc proc defaults 0 0 
    none /dev/shm tmpfs nodev,nosuid,noexec 0 0
    now, to make all this work, you will need to create the appropriate directory...
    so type in terminal
    Code:
    mkdir /mnt/HD_1
    mkdir /mnt/SCSI_1
    mkdir /mnt/SCSI_2
    mkdir /mnt/SCSI_3
    This will create all the directory, you can change the name thats not an issue, just make sure you change for the same data in your FSTAB file...

    After all this is in place, your ready to do this

    Hope this helps you
    Hit back if you need more info
    Code:
    mount -a
    and should be up and running
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  6. #6
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    I can see the drives now but when I type in:
    tux root # mount -a
    [mntent]: line 19 in /etc/fstab is bad
    [mntent]: line 20 in /etc/fstab is bad
    [mntent]: line 21 in /etc/fstab is bad

    I can still view them. But what did I do wrong. My /etc/fstab looks like this now:
    # /etc/fstab: static file system information.
    # $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03:38 azarah Exp $
    #
    # noatime turns off atimes for increased performance (atimes normally aren't
    # needed; notail increases performance of ReiserFS (at the expense of storage
    # efficiency). It's safe to drop the noatime options if you want and to
    # switch between notail and tail freely.

    # <fs> <mountpoint> <type> <opts> <dump/pass>

    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda2 /boot ext2 defaults,noatime 1 2
    /dev/hda4 / ext3 noatime 0 1
    /dev/hda3 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
    /dev/fd0 /mnt/floppy auto noauto 0 0

    /dev/hdb1 /mnt/HD_1 ntfs rw,umask=0 0 0
    /dev/sda1 /mnt/SCSI_1 vfat iocharset=iso8859-1, codepage=850,rw,umask=0 0 0
    /dev/sdb1 /mnt/SCSI_2 vfat iocharset=iso8859-1, codepage=850,rw,umask=0 0 0
    /dev/sdc1 /mnt/SCSI_3 vfat iocharset=iso8859-1, codepage=850,rw,umask=0 0 0
    # NOTE: The next line is critical for boot!
    none /proc proc defaults 0 0

    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    # use almost no memory if not populated with files)
    # Adding the following line to /etc/fstab should take care of this:

    none /dev/shm tmpfs nodev,nosuid,noexec 0 0
    Registered user #372186 -- http://counter.li.org

  7. #7
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    it could be somethinng else, but in your file i see this
    Code:
    iocharset=iso8859-1, codepage=850,rw,umask=0
    the correct one is like this
    Code:
    iocharset=iso8859-1,codepage=850,rw,umask=0
    no space between all of this
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  8. #8
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    That worked perfectly. You are so much help on this forum. Do I need root permission every time I want to see these drives?
    Registered user #372186 -- http://counter.li.org

  9. #9
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Quote Originally Posted by lokoalex
    That worked perfectly. You are so much help on this forum.
    No problem
    the comment is appreciated BTW
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  10. #10
    e2k
    e2k is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    41
    Quote Originally Posted by lokoalex
    Do I need root permission every time I want to see these drives?
    To be able to mount drives as a normal user, add "user" to you mount options in /etc/fstab for the drives you want to mount..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •