Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all guys...i am into a very deep problem so i wish someone can help me out.. Stats: 2004.3 stage3, xorg, KDE 3.3.0, fluxbox How the problem started.. -I was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6

    KDE and xorg *pretty* fscked up


    Hi all guys...i am into a very deep problem so i wish someone can help me out..

    Stats: 2004.3 stage3, xorg, KDE 3.3.0, fluxbox

    How the problem started..

    -I was logued in a KDE session as the normal user. Just wanted to change the KDE bin icon, so i went to the nuvola icons theme (i was using that one) folder. And first made a backup of the original icons, then overwrited the old for the news.............then i *try* to restart KDE so i LOGOUT and the FIRST error message come..............i just clicked OK without reading first (winbugs roots...), but id said something about "log" that it couldn't log into a file.

    -So once in KDM i realize that everytime i want to loguin, i just get a blank screen and back to to KDM. It doesn't matter if it is a KDE or FluxBox ssesion, and also doesn't matter if i use KDM, GDM or Entrance the user always have this problem.......BUT the root does not suffers this. I can loguin to any session with any Loguin Manager as root.


    What i did:...

    Read google like a maniac and this forums too. Any result yet. Information i gathered was.... first time was an error with /home/USER/.DCOPserver_magobox__0 and it said also to check that "dcopserver" program was running. Also this message "There was an error setting up inter-process communications for KDE".
    I made some changes to permissions to .ICEauthority and the new error was that "device /home/...*don't remember the rest*" was out of disk space (i still have 7 gigs free). Then frustrated i erased the whole /tmp directory. And got new errors, but i made a backup and replaced it. Now my error is with "xf86OpenConsole"
    I also tried making "genmdk.. --no-old" but never worked.
    Also tried re-emerging KDE and did't work. Emerged GNOME but that sessions gives me even more errors.


    So, i am almost crying to death here....what could be done??
    How can i get RIP totally of XORG, KDE, GNOME, Fluxbox and leave JUST the base system to emerge everything again??

    REPEAT: this sypmtop is only for USERS, ROOT is inmmune to all this problems.

    Any help is really really appreciated!! Thanks in advance.

    Mod Edit: Title censored. Please watch your language.

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    if root is still working fine, try wiping your home directorys and then recreating your user, its likely that a temp file in ~/.kde got corrupted or summin and is causing your grief.


    DON'T FORGET TO BACKUP ANY DATA YOU WANT TO KEEP!
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    qub333, thanks for posting...
    yep, i already did that....
    also created new users but they suffers the same problem...

    i had backup of all important data, i just don't want to install again 'cause that would cause to install windows again....and i HATE, HATE install windows ....

    thanks anyway!!!

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    that wouldnt cause u to install windows again ...you just dont format the windows partition...just ignore it..... but it is better to try to find the problem than to start over you will learn so much more!
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  5. #5
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    well, you could always try

    emerge -C xorg-x11 kde kdm

    then

    emerge sync

    emerge xorg-x11 kde kdm

    (im guessing that kdm is a package.. but it might just be part of KDE, what do i know about X.. little... very little.)
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    loft306: besides i am going to re-install Gentoo right now, (i hope LILO don't fail on me...) i got the problem cause.
    What happened is that a lot of binaries lost their SUID bits and some permissions.

    qub333: i already did that, but like before i keep getting the same errors..

    thanks to everybodu that has answred..

    wish me luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •