Find the answer to your Linux question:
Results 1 to 4 of 4
i have recently moved my gentoo 2004.3 box into the testing/unstable portage tree with accept keywords = ~x86, and recompiled the entire system twice to ensure that everything is compiled ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    31

    Hostname / Domainname problems


    i have recently moved my gentoo 2004.3 box into the testing/unstable portage tree with accept keywords = ~x86, and recompiled the entire system twice to ensure that everything is compiled with nptl and gcc 3.4.3. only one problem exists still, and that is the new gentoo base system, and its absolute REFUSAL to set my hostname and domainname

    here is the data that is in /etc/rc.conf, /etc/conf.d/hostname and /etc/conf.d/domainname and /etc/resolv.conf

    /etc/rc.conf

    Code:
    # /etc/rc.conf: Global startup script configuration settings
    # $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/rc.conf,v 1.30 2004/11/24 16:49:05 vapier Exp $
    
    # UNICODE specifies whether you want to have UNICODE support in the console.
    # If you set it to yes, please make sure to set a UNICODE aware CONSOLEFONT
    # and KEYMAP.
    
    UNICODE="no"
    
    # CONSOLEFONT specifies the default font that you'd like Linux to use on the
    # console.  You can find a good selection of fonts in /usr/share/consolefonts;
    # you shouldn't specify the trailing ".psf.gz", just the font name below.
    # To use the default console font, comment out the CONSOLEFONT setting below.
    # This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
    # not want to use it, run "rc-update del consolefont" as root).
    
    CONSOLEFONT="default8x16"
    
    # CONSOLETRANSLATION is the charset map file to use.  Leave commented to use
    # the default one.  Have a look in /usr/share/consoletrans for a selection of
    # map files you can use.
    
    #CONSOLETRANSLATION="8859-1_to_uni"
    
    # Set EDITOR to your preferred editor.  You may use something other than
    # what is listed here.
    
    EDITOR="/bin/nano"
    #EDITOR="/usr/bin/vim"
    #EDITOR="/usr/bin/emacs"
    
    # Set PROTOCOLS to the protocols that you plan to use.  Gentoo Linux will only
    # enable module auto-loading for these protocols, eliminating annoying module
    # not found errors.
    #
    # NOTE: Do NOT uncomment the next lines, but add them to 'PROTOCOLS=...' line!!
    #
    # Num   Protocol
    # 1:    Unix
    # 2:    IPv4
    # 3:    Amateur Radio AX.25
    # 4:    IPX
    # 5:    DDP / appletalk
    # 6:    Amateur Radio NET/ROM
    # 9:    X.25
    # 10:   IPv6
    # 11:   ROSE / Amateur Radio X.25 PLP
    # 19:   Acorn Econet
    
    # Most users want this:
    PROTOCOLS="1 2"
    
    #For IPv6 support:
    #PROTOCOLS="1 2 10"
    
    # What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
    #DISPLAYMANAGER="xdm"
    
    # XSESSION is a new variable to control what window manager to start
    # default with X if run with xdm, startx or xinit.  The default behavior
    # is to look in /etc/X11/Sessions/ and run the script in matching the
    # value that XSESSION is set to.  The support scripts are smart enough to
    # look in all bin directories if it cant find a match in /etc/X11/Sessions/,
    # so setting it to "enlightenment" can also work.  This is basically used
    # as a way for the system admin to configure a default system wide WM,
    # allthough it will work if the user export XSESSION in his .bash_profile, etc.
    #
    # NOTE:  1) this behaviour is overridden when a ~/.xinitrc exists, and startx
    #           is called.
    #        2) even if ~/.xsession exists, if XSESSION can be resolved, it will
    #           be executed rather than ~/.xsession, else KDM breaks ...
    #
    # Defaults depending on what you install currently include:
    #
    # Gnome - will start gnome-session
    # kde-<version> - will start startkde &#40;ex&#58; kde-3.0.2&#41;
    # Xsession - will start a terminal and a few other nice apps
    
    XSESSION="kde-3.3.2"
    /etc/conf.d/hostname

    Code:
    # Copyright 1999-2004 Gentoo Foundation
    # Distributed under the terms of the GNU General Public License v2
    # $Header&#58; /var/cvsroot/gentoo-src/rc-scripts/etc/conf.d/hostname,v 1.2 2004/11/15 19&#58;08&#58;37 vapier Exp $
    
    # Set to the hostname of this machine
    HOSTNAME="localhost"
    /etc/conf.d/domainname

    Code:
    # Copyright 1999-2004 Gentoo Foundation
    # Distributed under the terms of the GNU General Public License v2
    # $Header&#58; /var/cvsroot/gentoo-src/rc-scripts/etc/conf.d/domainname,v 1.1 2004/11/15 15&#58;43&#58;28 vapier Exp $
    
    # When setting up resolv.conf, what should take precedence?
    # If you wish to always override DHCP/whatever, set this to 1.
    OVERRIDE=1
    
    # To have a proper FQDN, you need to setup /etc/hosts and /etc/resolv.conf
    # properly &#40;domain entry in /etc/resolv.conf, and FQDN in /etc/hosts&#41;.
    #
    DNSDOMAIN="localdomain"
    
    # This only set what /bin/hostname returns.  If you need to setup NIS, meaning
    # what /bin/domainname returns, please see&#58;
    #
    #   http&#58;//www.linux-nis.org/nis-howto/HOWTO/
    #
    #NISDOMAIN=""
    /etc/resolv.conf

    Code:
    nameserver 204.127.202.4
    nameserver 216.148.227.68
    search mchsi.com
    i would like my hostname to be localhost.localdomain please.

    let me know what ya think, and thanks for the help in advance. let me know if yo need more info *etc additional file listings, and ill get them for you*

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Did you add the init scripts to default bootlevel?

    Code:
    rc-update add hostname default
    rc-update add domainname default
    And start them (without rebooting):

    Code:
    /etc/init.d/hostname start
    /etc/init.d/domainname start
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    31
    heh. Oops.

    Thank you For some reason they werent marked to start up boot

    Sorry for wasting your time

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by linux_se7en
    heh. Oops.

    Thank you For some reason they werent marked to start up boot

    Sorry for wasting your time
    No problem, man. We all forget things sometimes.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •