Hi all!! i hope this problem manages to get solved...

I am using Gentoo 2004.3 with gentoo-dev-sources on a P4@2800 mhz with 512Mb RAM

I recompiled my kernel (2.6.9-gentoo-r1) and everything worked fine except one thing..
i noticed during boot (in the messages) that it gaved me some erros that not were normal...i made a dmesg and i found this *not-so-good* messages...

Unable to handle kernel paging request at virtual address 0032004f
printing eip:
c0133b8b
*pde = 00000000
Oops: 0000 [#1]
PREEMPT SMP
Modules linked in: nvidia
CPU: 0
EIP: 0060:[<c0133b8b>] Tainted: P VLI
EFLAGS: 00010296 (2.6.9-gentoo-r1)
EIP is at print_unload_info+0x39/0xee
eax: 00000000 ebx: 0032004f ecx: c041023f edx: 00001000
esi: e126af80 edi: dfd5d5c0 ebp: e126af80 esp: c1609ef4
ds: 007b es: 007b ss: 0068
Process modprobe (pid: 6341, threadinfo=c1609000 task=df6cab70)
Stack: dfd5d5c0 c041023b 00000000 00000000 e126af84 e126af80 dfd5d5c0 c1609fac
c0135f37 dfd5d5c0 e126af80 e126af8c 00497414 e126af84 dfd5d5c0 e126af84
c0177b25 dfd5d5c0 e126af84 00000000 dfd5d5d8 00000000 df7bc38c df7bc384
Call Trace:
[<c0135f37>] m_show+0x3e/0x9f
[<c0177b25>] seq_read+0xdc/0x29b
[<c0158414>] vfs_read+0xb5/0x165
[<c0158765>] sys_read+0x51/0x80
[<c01050fb>] syscall_call+0x7/0xb
Code: 24 c7 44 24 0c 00 00 00 00 89 2c 24 e8 d4 fd ff ff 89 3c 24 89 44 24 08 c7 44 24 04 3b 02 41 c0 e8 ed 44 04 00 8b 9d 00 02 00 00 <8b> 03 0f 18 00 90 8d b5 00 02 00 00 39 f3 74 2e c7 44 24 0c 01
the main problem is that it didn't load ANY module, i "normally" only have 5, wich are....

Module Size Used by
w83627hf 27432 -
i2c_sensor 4608 -
i2c_isa 2048 -
i2c_core 21632 -
nvidia 4813428 -
When i did an lsmod it just puts no modules and can't "put" the prompt again...it just get stucked...
The same thing happens when i try to start or stop lm_sensors.

When i rebotted to switch back to the old kernel, it didn't do it, it got stucked when unloading the modules. Had to push reset button....arrghhh....
So...i WISH anyone could help me out....

NOTES: (new stuff added to the kernel on the recompile)

[*] Loopback Device Support[*] Module Unloading[*] /proc/sys/cpu/ interface (2.4. / OLD)
<*> CPU frequency table helpers
<*> Intel Pentium 4 clock modulation
--- 'userspace' governor for userspace frequency scaling
[*] Use FIFO/DMA if available (EXPERIMENTAL)[*] IEEE 1284 transfer modes
<M> BT848 Video For Linux
bye!!!!...any help is really apreciatted!!!!