Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Is it possible? If so, how do I go about it? I have KDE 3.3 + source on a Mandrake 10.0 disc, so I'm wondering if I can use that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

    Installing KDE: stage 3 && no packages cd


    Is it possible? If so, how do I go about it?

    I have KDE 3.3 + source on a Mandrake 10.0 disc, so I'm wondering if I can use that instead of downloading the Gentoo Packages CD.

    The reason why an "emerge kde" won't work is becuase my network drivers refuse to be recognised (I'm the same guy with the PCI-E Gigabit Ethernet problem). I need KDE so I can easily access the hardware configuration to get my network up and running.

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    why doesn't the network driver work? From the gentoo liveCD:
    Code:
    net-config eth0
    make sure that you're using the right hw address, and yes, you should be able to use the mandrake packages

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43
    I have tried everything (including 'net-config eth0'). I tried installing the Marvel Yukon Gigabit Ethernet driver from source. That failed - worse, the installation log file doesn't give any information about the "compiler error" that is supposedly the reason for the driver not compiling (I even tried setting my cflags to the simplest possible string: "-03 -pipe").
    It's good to know that I can use the mandrake disc, but is there a simple way to install kde from the disc w/out having to know where each and every single kde source/binary file is supposed to go?

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    the driver for this nic is in the kernel ! it is
    Code:
     sk98lin
    it is listed under
    Code:
      Device Drivers  --->Networking support  ---> Ethernet &#40;1000 Mbit&#41;  --->  < > Marvell Yukon Chipset / SysKonnect SK-98xx Support
    now if you make it as a module then after the kernel re compile then u need to add it to
    Code:
     /etc/modules.autoload.d/kernel-2.x
    then
    Code:
    modprobe sk98lin
    or simply mark it as y(*) and make it as a driver and nothing else needs be dono after the re compile.
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43
    loft306, I have tried that many times already. However, regardless of whether I integrate it into the kernel or make it a separate module (in which case i do a "make && make modules_install"), it fails to compile the kernel-driver/module for sk98lin. Problem is, the error message itself doesn't give any reason for the compilation failure; it just says it can't compile it!

  6. #6
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43
    Alright, these are the messages generated by the command 'make' after integrating the sk98lin driver into the kernel:
    Code:
      CHK     include/linux/version.h
    make&#91;1&#93;&#58; `arch/i386/kernel/asm-offsets.s' is up to date.
      CHK     include/linux/compile.h
      CC      drivers/net/sk98lin/skge.o
    drivers/net/sk98lin/skge.c&#58; In function `sk98lin_init_device'&#58;
    drivers/net/sk98lin/skge.c&#58;431&#58; error&#58; structure has no member named `last_stats'
    drivers/net/sk98lin/skge.c&#58;566&#58; error&#58; structure has no member named `last_stats'
    make&#91;3&#93;&#58; *** &#91;drivers/net/sk98lin/skge.o&#93; Error 1
    make&#91;2&#93;&#58; *** &#91;drivers/net/sk98lin&#93; Error 2
    make&#91;1&#93;&#58; *** &#91;drivers/net&#93; Error 2
    make&#58; *** &#91;drivers&#93; Error 2
    The output for the modularised setting is very similar (in essence, the source code errors persist).

  7. #7
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

  8. #8
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

  9. #9
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

  10. #10
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •