Find the answer to your Linux question:
Results 1 to 8 of 8
Why am I getting a message after I reboot and chose my my OS that says: Code: mtrr: size and base must be multiples of 4 kiB...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102

    Problems after rebooting after Grub install


    Why am I getting a message after I reboot and chose my my OS that says:

    Code:
    mtrr: size and base must be multiples of 4 kiB
    Registered user #372186 -- http://counter.li.org

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    what do you have in your grub.conf file?

    post the whole of the gentoo section.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    Code:
    default 0
    timeout 30
    
    splashimage=(hd0,0)/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.10-r6
    root (hd0,0)
    kernel /boot/kernel-2.6.10-gentoo-r6 boot=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3 vga=791
    initrd /boot/initrd-2.6.10-gentoo-r6
    Registered user #372186 -- http://counter.li.org

  4. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    I don't know if this is what's causing the problem, but try taking out all that stuff on the end of the kernel line, and try booting without the initrd.

  5. #5
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    I just read that there is a bug in that kernel. Does anyone know if the bug is fixed? Or how I can use a different kernel. I cant get the program to load up, what should I do to install an older kernel version?
    Registered user #372186 -- http://counter.li.org

  6. #6
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    The bug had to do with lba mode, which doesn't seem to be the problem here.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #7
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    I removed initrd and that did nothing. What do you guys recommend? Im still getting that message.
    Registered user #372186 -- http://counter.li.org

  8. #8
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Jersey
    Posts
    102
    I got it to work. Someone told me it had to do with frambuffer so I turned off framebuffer support in the kernel options. And it works fine.
    Registered user #372186 -- http://counter.li.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •