Find the answer to your Linux question:
Results 1 to 10 of 10
Hi, I have a problem weith my network card, during the installation everything was fine, but after the final reboot i got this error message : Bringing eth0 up via ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7

    Network Card


    Hi,

    I have a problem weith my network card, during the installation everything was fine, but after the final reboot i got this error message :

    Bringing eth0 up via DHCP... [!!]

    ERROR: Problem starting needed services.
    "netmount" was not started.

    And then if i try: ifconfig eth0 up i get the following error:
    eth0: unknown interface: No such device.

    My network card is an old Compaq NC3121..

    Did someone have any idea what i can do to make this work ?

    I'm new to Linux, first try after a life of Window ..

    Thank you.

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    can you post the output of ifconfig?
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    Sounds to me like you dont have the right network modules loading at boot time. Did you configure your modules.autoload.d to support your network card? Try doing modprobe <networkmodule> then run dhcpcd again.

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7
    Here's the output of ifconfig :

    Link encap : Local loopback
    inet addr : 127.0.0.1 mask : 255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX and TX : all 0

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7
    I have read something about this on Google.. but i don't know how to do this

    Don't even know where to find which <networkmodule> i need. ;o)

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    One way you can find out is to boot the live cd and then do an lsmod. The gentoo live cd uses the coldplug system to detect all your heardware. So if you boot from the live cd do
    lsmod it will display all the modules loaded. If you used genkernel chances are you could simply emerge coldplug and then the same autodection will be installed on your system to detect all your hardware. You may need to get the ebuild on the machine first or use the one from the universal live cd because you dont have any network yet. re-read the part in the gentoo handbook configuring the kernel. Torward the end you will find more details on this. You could also google it....

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    Your ethernet card is not being recognized.

    first: try ifconfig eth0 up ----then ifconfig ------if your device shows up now try the command dhcpd eth0 ----then try ping google.com ----if you get feedback your connection is working.
    (I've never done a setup not involving dhcp so if you have a static ip or something else I'll give the link that all this info comes from)

    Assuming that this works then you need to add a line to your net config (i think thats what it is but its irrevelant anyways) by typing nano -w /etc/conf.d/net and adding this iface_eth0="dhcp" this makes it so when you boot your computer will automatically activate your card and connect to the internet. Voila your done. That is if the first part worked which since you have an old card it might not. but there are two other options still to try (that I know of)

    use this command to see if you can find your card......
    ls /lib/modules/`uname -r`/kernel/drivers/net

    if you do see your card type this.........
    modprobe nameofyourcard ....where nameofyourcard is the actual name of your card!!!

    type ifconfig and see if your card is now detected...if it is then you can continue with instructions above starting with the dhcpd eth0 command!

    the last thing that I know of that might solve your problem...it solved my wireless card probem...is ndiswrapper. follow the instructions on this link and see if that works http://ndiswrapper.sourceforge.net/p...p/Installation

    its a little confusing but give it a shot and if you have any specific problems drop me a line or post --hope any or all of this helps some!


    here is link from gentoo site which I got most info from http://www.gentoo.org/doc/en/handboo...3#network_term
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    Maybe a solution...

    Hi,

    I got same king of problem installing the last Gentoo release (2005.0 staging 3).

    If nothing work, try to delete /etc/resolv.conf.
    It works for me :o)

    Don't really know the reason but I guess was related to a security issue or access right.

    Anyway, try it, never know but again, works for me.

  9. #9
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Spencerf: It is dhcpcd, not dhcpd...

    Also, when you chroot'ed into the enviroment through the live-cd, try running this command:
    Code:
    emerge livecd-tools
    Then, you can use "net-setup" or "net-setup eth0", i don't remember (Did it in my first gentoo-install, but don't have the time to compile it again now) and it will configure the network for you (requiring you having the right modules available)

  10. #10
    fro
    fro is offline
    Just Joined!
    Join Date
    May 2005
    Posts
    1
    I had the same problem.

    You just need to compile the kernel with appropriate network drivers flagged.

    Just flag -
    Networking Support
    Ethernet (10 or 100Mbit)
    Intel (R) PRO/100+ support

    That's all I had to do to get it working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •