Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, I've recently installed gentoo (w/ 2.6 kernel), and it seems to be running ok, except that many linux commands seem to be missing! when I try to run # ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    Playa Del Rey, CA
    Posts
    6

    Missing Commands


    Hello,
    I've recently installed gentoo (w/ 2.6 kernel), and it seems to be running ok, except that many linux commands seem to be missing! when I try to run # ftp, for example, I get "bash: ftp: command not found" the same thing happens when I try to run "iwconfig" (I'm trying to get my wireless card working). Is this related to my file system problem?

    when my computer boots up and starts its checks, I get a message that says

    "wrong fs type, bad option, or too many mounted file systems. Some local file systems failed to mount"

    How do I take care of these two problems?

    thanks, mj

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Are you sure the commands are gone? They may just not be in your path. As root in a terminal, type
    Code:
    whereis iwconfig
    and see if you get anything. If not, you may need to install a package...in Suse it's wireless-tools, but I have no idea what it is in Gentoo.

    The second problem is usually related to an error in your /etc/fstab file...if you run (as root)
    Code:
    fdisk -l
    and post the output, along with your fstab file, we may have something to work with.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Also, post the output of:

    Code:
    echo $PATH
    It seem as if your binaries in /usr/bin are missing...if something is failing to mount, that could be killing you.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Location
    Playa Del Rey, CA
    Posts
    6
    Thanks,
    I'll try this out.

    mj

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Playa Del Rey, CA
    Posts
    6

    Results so Far...

    Okay, here's the results of my fdisk -l:

    Code:
    device        boot      Start              End           Blocks        Id    System
    /dev/hda1     *            1                 63            31720+     83    Linux
    /dev/hda2                  64             1056         500472        82    Linux Swap
    /dev/hda3               1057             38760     19002816      83     Linux
    the results of echo $PATH are:

    Code:
    /bin:/sbin:/usr/bin:/usr/sbin/:/usr/local/bin:/opt/bin/:/usr/i386-pc-linux-gnu/gcc-bin/3.3
    Finally, my /etc/fstab file reads as follows:

    Code:
    /dev/hda1                    /boot            ext2        defaults,noatime        1 2
    /dev/cdroms/cdrom0    /mnt/cdrom   iso9660    noauto,user              0 0
    /dev/hda2                    none             swap        sw                           0 0
    /dev/hda3                     /                  ext2         noatime                   0 2
    none                            /dev/shm       tmpfs     novdev,nosuid,noexec 0 0
    none                           /proc/bus/usb  usbfs       defaults                    0 0
    (everything is lined up, of course)
    Let me know what you think...

    mj

  7. #6
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    One more thing...which device does it say "wrong fs type, bad option, or too many mounted file systems. Some local file systems failed to mount" about at boot?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  8. #7
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    If you have just installd gentoo then you won't have any other optional packages installed you will have to run

    Code:
    emerge -av ftp xfce4-base xmms
    or whatever else you want installed.

    (yes I noticed your other post and xfce is not an ebuild, its called xfce4-base)

    also you should install "esearch" and run "eupdatedb" then you can "esearch xfce" and it will show all the packages available with xfce in the title.

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Location
    Playa Del Rey, CA
    Posts
    6

    on commands...

    Variant, thanks, I'll try it out.

    Flatline-- I get the error message at boot, right after "Mounting Filesystems"

  10. #9
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    All I can think of is that you have specified the wrong filessystem type in the fstab for /boot. in your fstab you have /boot mounted as ext2.. are you sure thats what it is? perhaps you made it ext3 instead but forgot to alter the fstab.. do you rememebr running "mke2fs -j /dev/hda1"? if you use -j with mke2fs it will make a ext3 filesystem not ext2. all the rest seems to be correct. allthough ext2 seems a strange choice for the root filesystem (if this was the problem then the pc wouldnt even boot - so its not this) as ext3 or reiserfs is much more appropriate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •