Find the answer to your Linux question:
Page 4 of 6 FirstFirst 1 2 3 4 5 6 LastLast
Results 31 to 40 of 53
I am running kernel 2.6.11 and i have checked absolutely everything in the 10/100 ethernet section. I actually found a section for the type of chipset i have and i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6

    I am running kernel 2.6.11 and i have checked absolutely everything in the 10/100 ethernet section. I actually found a section for the type of chipset i have and i have enabled it, it's in the gigabit ethernet, and recompiled the kernel. still no go. I am using marvell yukon. Could it be something with the actual hosts file or hostname or comp name?

  2. #32
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    it could be, did you copy that information over from the live cd? what do you get if you type ifconfig -a ? if you don't see your card at this stage and only the local loopback especially after you reboot, and ifconfig eth0 up and then dhcpcd eth0 you know that it is an eth0 problem and not a hostname problem. Could you try these things and then ifconfig -a and post your output?
    Operating System: GNU Emacs

  3. #33
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    netmount and eth0

    I have the same board, and running into the same problems. I had to stop last night or i was going to beat it with a shovel.

    it would seem the the you need a driver not included, more specifically.. the one mentioned in this thread http://forums.gentoo.org/viewtopic-t-319981.html (Marvell 88E8001 GbE Gigabit Lan PCI Controller supporting 10/100/1000 BASE-T Ethernet --asus.com)

    I really hope this helps out, as i haven't had a chance to try this myself yet. I've been away from my machine all day and had some time to do some research.

    Good luck, i'll post my results when i get back to my machine....

  4. #34
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    Success

    The module you need to enable is in:
    Ethernet 1000->
    then * the Marvell Chipset

    don't forget to mount /boot so when you recompile it will actually copy correctly to /boot

  5. #35
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    forgot to copy the kernel image and configs after setting the right drivers. I'm such a n00b.

  6. #36
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    [edit].......sorry didn't see there was a second page replied to the last message on page 1....[edit]

  7. #37
    Just Joined!
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    5

    I had duplicate error I solved by emerging coldplug

    Quote Originally Posted by SiberianX37
    Hi guys. I have been following along with this post and trying to solve a similar problem that i am having with gentoo. the livecd worked fine with the net, but now there are problems starting netmount. i have a router with dhcp . The difference is however, i don't have a nic card for ethernet, but my etherent is built into my asus a8v mobo. I have tried everything you guys have posted on this post and I am still unsuccessful. I might be a little screwed up on the settings i made in /etc/hosts so maybe that's it. please let me know what to do next. thank you.
    I don't know all this kernel stuff yet but I solved this error by emerging coldplug. The livecd doesn't bring up the network untill after coldplug. If you can boot up with the livecd, chroot in emerge coldplug and reboot.

    Sorry cant I give more accurate steps.

  8. #38
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Hey everyone. I've also been using this post to fix my networking problem but nothing has worked.

    I'm on kernel 2.6 and have tried checking all the networking device drivers to compile my kernel. I have hotplug and coldplug both emerged, but I just can't seem to get the kernel to detect my network card.

    ifconfig always returns the lo Local Loopback

  9. #39
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    What kind of card do you have?
    Are you using broadband/dsl?
    Can you post the contents of
    /etc/conf.d/net

    I just went through trying to get my netwrk up and running, and that is the file that I had errors in.

    My post and solution.
    http://www.linuxforums.org/forum/topic-41128.html

    I hope you can get this working.
    Gentoo without the net, just isn't right.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  10. #40
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Thanks for the reply! Gentoo really isn't as fun without emerge...

    I believe I have the Marvell driver that says "deprecated" but I've selected pretty much all the drivers just in case.

    I'm on a campus broadband network with DHCP.

    Here's the code with the uncommented settings:
    Code:
    #etc/conf.d/net
    
    iface_eth0="192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0" #enabled while troubleshooting
    
    iface_eth0="dhcp"
    dhcpcd_eth0="-HDN"
    edit: also, evdev, skge, and atkbd are returning an error during boot. evdev and skge were loaded during the boot of the livecd

Page 4 of 6 FirstFirst 1 2 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •