Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everyone, When I try to update my system with emerge -uD world (if I am using the wrong command, what command should I be using to update?), I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619

    emerge world problem


    Hi everyone,

    When I try to update my system with emerge -uD world (if I am using the wrong command, what command should I be using to update?), I get this error:
    Code:
    root@localhost bryan # emerge -uD world
    Calculating world dependencies ...done!
    
    !!! Error&#58; the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.
    !!!        both can't be installed on the same system together.
    !!!        Please use 'emerge --pretend' to determine blockers.
    
    root@localhost bryan # emerge --pretend world
    
    These are the packages that I would merge, in order&#58;
    
    Calculating world dependencies ...done!
    
    &#91;blocks B     &#93; <x11-base/xorg-x11-6.8.0-r4 &#40;from pkg x11-base/opengl-update-2.1.1-r1&#41;
    &#91;ebuild     U &#93; sys-apps/man-pages-2.01 &#91;1.67&#93;
    &#91;ebuild     U &#93; sys-libs/zlib-1.2.2 &#91;1.2.1-r3&#93;
    &#91;ebuild     U &#93; media-sound/alsa-headers-1.0.8 &#91;1.0.6a&#93;
    &#91;ebuild     U &#93; media-libs/alsa-lib-1.0.8 &#91;1.0.6&#93;
    &#91;ebuild     U &#93; media-sound/alsa-utils-1.0.8 &#91;1.0.6&#93;
    &#91;ebuild     U &#93; media-gfx/bootsplash-0.6.1-r7 &#91;0.6.1-r4&#93;
    &#91;ebuild     U &#93; sys-libs/cracklib-2.7-r11 &#91;2.7-r9&#93;
    &#91;ebuild     U &#93; app-text/ghostscript-7.07.1-r8 &#91;7.07.1-r7&#93;
    &#91;ebuild     U &#93; sys-apps/man-1.5p &#91;1.5m-r2&#93;
    &#91;ebuild     U &#93; sys-kernel/linux26-headers-2.6.8.1-r2 &#91;2.6.8.1&#93;
    &#91;ebuild     U &#93; sys-apps/pciutils-2.1.11-r3 &#91;2.1.11-r1&#93;
    &#91;ebuild     U &#93; sys-apps/hwsetup-1.0-r2 &#91;1.0-r1&#93;
    &#91;ebuild     U &#93; app-arch/cpio-2.6-r1 &#91;2.5&#93;
    &#91;ebuild     U &#93; sys-process/procps-3.2.4-r3 &#91;3.2.3-r1&#93;
    &#91;ebuild     U &#93; app-admin/syslog-ng-1.6.5-r2 &#91;1.6.5-r1&#93;
    &#91;ebuild     U &#93; app-arch/gzip-1.3.5-r5 &#91;1.3.5-r2&#93;
    &#91;ebuild     U &#93; net-misc/wget-1.9.1-r3 &#91;1.9-r2&#93;
    &#91;ebuild     U &#93; net-misc/openssh-3.9_p1-r2 &#91;3.8.1_p1-r1&#93;
    &#91;ebuild     U &#93; sys-devel/gcc-3.3.5-r1 &#91;3.3.4-r1&#93;
    &#91;ebuild     U &#93; sys-devel/bin86-0.16.16 &#91;0.16.0&#93;
    &#91;ebuild     U &#93; sys-fs/reiserfsprogs-3.6.19 &#91;3.6.18&#93;
    &#91;ebuild     U &#93; sys-devel/libtool-1.5.10-r4 &#91;1.5.2-r5&#93;
    &#91;ebuild     U &#93; sys-apps/gawk-3.1.3-r2 &#91;3.1.3-r1&#93;
    &#91;ebuild     U &#93; sys-apps/hwdata-knoppix-0.107-r1 &#91;0.107&#93;
    &#91;ebuild     U &#93; sys-devel/bc-1.06-r6 &#91;1.06-r5&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-mime-data-2.4.2 &#91;2.4.1&#93;
    &#91;ebuild     U &#93; x11-libs/gtksourceview-1.1.1 &#91;1.0.1&#93;
    &#91;ebuild     U &#93; app-editors/gedit-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; dev-libs/glib-2.6.2-r1 &#91;2.4.7&#93;
    &#91;ebuild     U &#93; x11-libs/pango-1.8.1 &#91;1.6.0&#93;
    &#91;ebuild     U &#93; x11-libs/gtk+-2.6.2 &#91;2.4.9-r1&#93;
    &#91;ebuild     U &#93; media-gfx/eog-2.8.2 &#91;2.8.1&#93;
    &#91;ebuild     U &#93; gnome-base/eel-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-base/nautilus-2.8.2-r1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-applets-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; dev-libs/libxslt-1.1.12 &#91;1.1.9-r1&#93;
    &#91;ebuild     U &#93; gnome-extra/gnome2-user-docs-2.8.1 &#91;2.8.0.1&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-session-2.8.1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-extra/gal-2.2.4 &#91;2.2.3&#93;
    &#91;ebuild     U &#93; x11-wm/metacity-2.8.8 &#91;2.8.5&#93;
    &#91;ebuild     U &#93; media-libs/gstreamer-0.8.8 &#91;0.8.7&#93;
    &#91;ebuild     U &#93; gnome-extra/evolution-data-server-1.0.3 &#91;1.0.2&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-desktop-2.8.1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-base/control-center-2.8.1-r1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-extra/gnome-system-monitor-2.8.1-r1 &#91;2.7.0-r1&#93;
    &#91;ebuild     U &#93; gnome-base/librsvg-2.8.1-r1 &#91;2.8.1&#93;
    &#91;ebuild     U &#93; gnome-extra/zenity-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-base/libgtop-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-base/gconf-2.8.1-r1 &#91;2.8.0.1&#93;
    &#91;ebuild     U &#93; gnome-extra/gconf-editor-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-extra/libgtkhtml-3.2.4 &#91;3.2.3&#93;
    &#91;ebuild     U &#93; mail-client/evolution-2.0.3-r2 &#91;2.0.2&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-panel-2.8.2 &#91;2.8.0.1&#93;
    &#91;ebuild     U &#93; app-text/ggv-2.8.1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; x11-themes/gnome-themes-2.8.1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; dev-libs/libxml2-2.6.16 &#91;2.6.15-r1&#93;
    &#91;ebuild     U &#93; gnome-extra/gcalctool-4.4.20 &#91;4.4.19&#93;
    &#91;ebuild     U &#93; gnome-extra/gnome-utils-2.8.1 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-extra/gnome-games-2.8.2 &#91;2.8.1&#93;
    &#91;ebuild     U &#93; media-libs/gst-plugins-0.8.7 &#91;0.8.5-r1&#93;
    &#91;ebuild     U &#93; media-plugins/gst-plugins-esd-0.8.7 &#91;0.8.5&#93;
    &#91;ebuild     U &#93; media-plugins/gst-plugins-alsa-0.8.7-r1 &#91;0.8.5&#93;
    &#91;ebuild     U &#93; media-plugins/gst-plugins-oss-0.8.7 &#91;0.8.5&#93;
    &#91;ebuild     U &#93; gnome-base/gdm-2.6.0.6 &#91;2.6.0.4-r1&#93;
    &#91;ebuild     U &#93; gnome-extra/gucharmap-1.4.2 &#91;1.4.1&#93;
    &#91;ebuild     U &#93; gnome-base/libgnomeprint-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; x11-libs/libxklavier-1.04-r1 &#91;1.03&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-vfs-2.8.3-r1 &#91;2.8.1-r2&#93;
    &#91;ebuild     U &#93; gnome-base/libgnomeprintui-2.8.2 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; gnome-extra/yelp-2.6.5 &#91;2.6.4&#93;
    &#91;ebuild  N    &#93; net-www/mozilla-1.7.5
    &#91;ebuild  N    &#93; net-www/epiphany-1.4.6
    &#91;ebuild     U &#93; net-misc/vino-2.8.1 &#91;2.8.0.1&#93;
    &#91;ebuild     U &#93; app-text/gpdf-2.8.2 &#91;2.8.0-r2&#93;
    &#91;ebuild     U &#93; app-arch/file-roller-2.8.3 &#91;2.8.0&#93;
    &#91;ebuild     U &#93; x11-libs/libwnck-2.8.1 &#91;2.8.0.1&#93;
    &#91;ebuild     U &#93; x11-terms/gnome-terminal-2.8.2 &#91;2.7.3&#93;
    &#91;ebuild     U &#93; app-admin/gnome-system-tools-1.0.2-r1 &#91;1.0.0&#93;
    &#91;ebuild     U &#93; x11-libs/vte-0.11.11-r2 &#91;0.11.11-r1&#93;
    &#91;ebuild     U &#93; gnome-base/gnome-2.8.2 &#91;2.8.0-r1&#93;
    &#91;ebuild     U &#93; sys-libs/glibc-2.3.4.20041102-r1 &#91;2.3.4.20040808-r1&#93;
    &#91;ebuild     U &#93; sys-apps/kbd-1.12-r3 &#91;1.12-r2&#93;
    &#91;ebuild     U &#93; sys-devel/binutils-2.15.92.0.2-r1 &#91;2.14.90.0.8-r1&#93;
    &#91;ebuild     U &#93; sys-apps/file-4.12 &#91;4.10&#93;
    &#91;ebuild     U &#93; app-arch/bzip2-1.0.2-r5 &#91;1.0.2-r3&#93;
    &#91;ebuild     U &#93; sys-apps/portage-2.0.51.19 &#91;2.0.51-r3&#93;
    *** Portage will stop merging at this point and reload itself,
        recalculate dependencies, and complete the merge.
        You may avoid the remerging of packages by updating portage on its own.
    &#91;ebuild     U &#93; net-dialup/rp-pppoe-3.5-r7 &#91;3.5-r2&#93;
    &#91;ebuild     U &#93; media-libs/freetype-2.1.9-r1 &#91;2.1.5-r1&#93;
    &#91;ebuild     U &#93; x11-base/opengl-update-2.1.1-r1 &#91;1.8.2&#93;
    &#91;ebuild     U &#93; x11-base/xorg-x11-6.8.2-r1 &#91;6.8.0-r3&#93;
    &#91;ebuild     U &#93; sys-libs/libaal-1.0.3 &#91;1.0.1&#93;
    &#91;ebuild     U &#93; sys-fs/reiser4progs-1.0.3 &#91;1.0.1&#93;
    &#91;ebuild     U &#93; sys-apps/shadow-4.0.5-r3 &#91;4.0.4.1-r4&#93;
    &#91;ebuild     U &#93; sys-apps/groff-1.19.1-r2 &#91;1.18.1-r4&#93;
    &#91;ebuild     U &#93; sys-apps/diffutils-2.8.7 &#91;2.8.4-r4&#93;
    &#91;ebuild     U &#93; sys-apps/ed-0.2-r6 &#91;0.2-r4&#93;
    &#91;ebuild  NS   &#93; sys-libs/db-1.85-r2
    &#91;ebuild  N    &#93; sys-libs/gdbm-1.8.3-r1
    &#91;ebuild     U &#93; dev-lang/python-2.3.4-r1 &#91;2.3.4&#93;
    &#91;ebuild     U &#93; sys-devel/gnuconfig-20050223 &#91;20040214&#93;
    &#91;ebuild  N    &#93; app-crypt/hashalot-0.3
    &#91;ebuild     U &#93; sys-apps/util-linux-2.12i-r1 &#91;2.12-r4&#93;
    &#91;ebuild     U &#93; sys-apps/net-tools-1.60-r11 &#91;1.60-r9&#93;
    &#91;ebuild     U &#93; sys-apps/baselayout-1.9.4-r6 &#91;1.9.4-r3&#93;
    &#91;ebuild     U &#93; sys-devel/bison-1.875d &#91;1.875&#93;
    &#91;ebuild     U &#93; net-misc/rsync-2.6.0-r4 &#91;2.6.0-r3&#93;
    &#91;ebuild     U &#93; net-wireless/wireless-tools-27 &#91;27_pre26&#93;
    &#91;ebuild  N    &#93; dev-perl/Locale-gettext-1.01-r1
    &#91;ebuild  N    &#93; sys-apps/help2man-1.33.1
    &#91;ebuild     U &#93; sys-apps/coreutils-5.2.1-r4 &#91;5.2.1&#93;
    &#91;ebuild     U &#93; sys-process/psmisc-21.5 &#91;21.4&#93;
    &#91;ebuild     U &#93; sys-devel/m4-1.4.2-r1 &#91;1.4.1&#93;
    &#91;ebuild     U &#93; dev-python/pyxml-0.8.3-r1 &#91;0.8.3&#93;
    &#91;ebuild     U &#93; sys-devel/libperl-5.8.5 &#91;5.8.4-r1&#93;
    &#91;ebuild     U &#93; dev-lang/perl-5.8.5-r5 &#91;5.8.4-r1&#93;
    I added the pretend to show what was wrong at the first line. How do I get around this block of xorg? By the way, I am using VidaLinux, so if there is anything that is really Gentoo specific, I will try it but I am not sure if it will work (although it should because it is Gentoo based).

    Thanks,
    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    try this if you are just trying to update your system. Because the error message it looks as if portage is actually trying to install a package in which Xorg is a blocker.

    emerge --update --deep world (make sure you are root)

    I would read the relevant sections on portage from this page:
    http://www.gentoo.org/doc/en/index.xml?catid=gentoo
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Hi,

    Thanks for the help but I have decided to switch back to Suse for now for a couple of reasons. Thanks for the help anyway.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    I've found a solution to this

    You need to first emerge x.org without checking dependencies like so
    Code:
    emerge --nodeps xorg-x11
    Now you can emerge world and the block is gone. Otherwise I think you will never get past the fact that emerging xorg-x11 is dependent on a package that is blocked by your current x.org version.

  6. #5
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Thanks for the reply. I think I may want to try a Gentoo based system later on and it will be helpful to know this for later.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •