Find the answer to your Linux question:
Results 1 to 2 of 2
Since this problem is getting increasingly annoying, I'll post the solution here. Hopefully, someone'll sticky it. The current stable version of nvidia-kernel does not work with the latest gentoo-dev-sources, so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Somewhere
    Posts
    47

    Why nvidia module won't load on 2.6.11 (and other problems)


    Since this problem is getting increasingly annoying, I'll post the solution here. Hopefully, someone'll sticky it.

    The current stable version of nvidia-kernel does not work with the latest gentoo-dev-sources, so you have to use the testing version. To do this, you have to log into root and type in the following commands.

    # echo "media-video/nvidia-kernel ~x86" >> /etc/portage/package.keywords
    # emerge nvidia-kernel
    Also, unless you emerge alsa-utils again, your going to get an error when ALSA tries to restore the mixer settings. ALSA will work fine, but to have to emerge alsa-utils to get rid of the error.

    Chris

    P.S.

    I may edit this in the future for a few other programs that need to be tweaked to run on 2.6.11.

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    Also, some of the early releases of the 2.6.11 kernel have problems inserting modules, you might want to try downloading the latest release from kernel.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •