Find the answer to your Linux question:
Results 1 to 3 of 3
Code: /usr/share/apr-0/build/libtool --silent --mode=link i686-pc-linux-gnu-gcc -pthread -O3 -march=athlon-xp -fomit-frame-pointer -pipe -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER -I/usr/include/apr-0 -I. -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/os/unix -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/server/mpm/prefork -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/http -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/filters -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/proxy -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/include -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/generators -I/usr/include/openssl ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201

    Apache compile error


    Code:
    /usr/share/apr-0/build/libtool --silent --mode=link i686-pc-linux-gnu-gcc  -pthread  -O3 -march=athlon-xp -fomit-frame-pointer -pipe  -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   -I/usr/include/apr-0 -I. -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/os/unix -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/server/mpm/prefork -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/http -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/filters -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/proxy -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/include -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/generators -I/usr/include/openssl -I/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/modules/dav/main -export-dynamic -L/usr/lib   -o htdigest  htdigest.lo   -lz -lssl -lcrypto -ldl /var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/srclib/pcre/libpcre.la /usr/lib/libaprutil-0.la -lgdbm -ldb -lexpat /usr/lib/libapr-0.la -lrt -lm -lcrypt -lnsl -lpthread -ldl
    /usr/lib/libaprutil-0.so: undefined reference to `db_create_4001'
    /usr/lib/libaprutil-0.so: undefined reference to `db_strerror_4001'
    collect2: ld returned 1 exit status
    make[2]: *** [htpasswd] Error 1
    make[2]: *** Waiting for unfinished jobs....
    /usr/lib/libaprutil-0.so: undefined reference to `db_create_4001'
    /usr/lib/libaprutil-0.so: undefined reference to `db_strerror_4001'
    collect2: ld returned 1 exit status
    make[2]: *** [htdigest] Error 1
    make[2]: Leaving directory `/var/tmp/portage/apache-2.0.53/work/httpd-2.0.53/support'
    make[1]: *** [all-recursive] Error 1
    Any ideas? Im lost and google has nothing
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    looks like libaprutil was compiled incorrectly, you could grep all the system headers and find a refernce to db_create_4001 and add an #include statement to whatever file was compiled into libpcre.la, but you might want to try compiling the program yourself, and also libaprutil

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by smindinvern
    looks like libaprutil was compiled incorrectly, you could grep all the system headers and find a refernce to db_create_4001 and add an #include statement to whatever file was compiled into libpcre.la, but you might want to try compiling the program yourself, and also libaprutil
    I'd suggest re-compiling libaprutil (or whatever that library comes from) as well as making sure it's an up-to-date version (or that apache is an up-to-date version ). Also run 'ldconfig' to make sure all your linked libraries are up to date.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •