Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, my problem is that i can't find why i cannot use a resolution greater that 640x480 in KDE.. I use a ATI Radeon 9600XT. My XF86Config-4 file appear to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7

    KDE - 640x480 Only


    Hi,

    my problem is that i can't find why i cannot use a resolution greater that 640x480 in KDE..

    I use a ATI Radeon 9600XT.

    My XF86Config-4 file appear to be OK, but maybe i forgot something somewhere else.

    It's the frist time i use Linux, and KDE, so i don't know where to look..

    By the way, if i do a "lsmod" the only modules listed is 3c59x.

    Thanks

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    post your XFree86.conf file, and try doing Ctrl+Alt+(+/-) to switch resolutions

  3. #3
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    I had this problem on my Gentoo as well, on an nVidia card. You can edit your /etc/X11/xorg.conf file under the section "Screen" to set your default resolutions. Here's how I set mine.

    Code:
    # This section contains information for the default display settings.
    Section "Screen"
         # The identifier is what the screen setup is known as by Xorg.
            Identifier "Screen0"
         # The device is the name of the display device <in this case whatever your Radeon is known as farther up in this file> you wish to use with X.
            Device     "Card0"
         # The monitor is the name of the monitor which X will be displayed on.
            Monitor    "Monitor0"
         # The default depth is the color depth in bits which you would prefer X to be displayed in. 24-bit  color depth is elsewhere known as 32-bit depth for rather stupid reasons. The setting of this variable will direct X to the subsection with the specified depth for display modes.
            DefaultDepth 24
         # This subsection is for 24-bit color depth.
            SubSection "Display"
         # No clue what Viewport does. Just leave it as 0 0.
                    Viewport   0 0
         # Specifies that this is the 24-bit depth display.
                    Depth     24
         # This specifies what resolutions to attempt to run X in, from left to right.
                    Modes  "1280x1024" "1024x768" "800x600"
            EndSubSection
    EndSection
    Hope this helps you out!
    --Dachnaz [Fuzzy Llama]

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    make sure your monitor settings are correct as well, especially the vertical and horizontal sync settings, and that you have it set up to handle other resolutions, not only on the graphics card.

    your screen0, and monitor0 within the displace look ok as well, but also check your monitor settings.

    you may want to check another xwm along with kde to make sure that it is not a problem specific to kde on your system, e.g. if it works on fluxbox or enlightenment then it is a kde problem and not an x problem.

    good luck
    Operating System: GNU Emacs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •