Find the answer to your Linux question:
Results 1 to 8 of 8
~new to forum~ Hmm... Well first off hello to all. Soo, I've trudged my way through my first gentoo install. I don't think I've had that much fun in a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7

    Hi! .....no sound! (SOLVED)


    ~new to forum~
    Hmm... Well first off hello to all.

    Soo, I've trudged my way through my first gentoo install. I don't think I've had that much fun in a long time.... ~not sure whether or not that was sarcasm~.

    Seems the only thing I have left to figure out.....

    after xorg.conf not working with monitor settings that EXACTLY matched those of the owners manual and a mouse that fought with everything it had to not have to let me use the scroll wheel.....

    ...is SOUND.

    Like...i can't hear any.

    I like to figure these things out as much on my own as i can... because i am relatively clueless and have a complex about it... but i find myself here needing a point in the right direction.

    Thanks in advance for any help anyone has to offer.

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    I would say that most likely the problem is that you haven't configured alsa, try running from a terminal/cli:
    Code:
    alsamixer
    make sure that everything is unmuted and configured correctly, then do:
    Code:
    alsactl save

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    Tried to run alsamixer and couldn't....
    emerge alsa-driver gave me this result:

    >>> emerge (1 of 1) media-sound/alsa-driver-1.0.8 to /
    >>> md5 src_uri alsa-driver-1.0.8.tar.bz2
    * Determining the location of the kernel source code
    * Found kernel source directory:
    * /usr/src/linux
    * Found sources for kernel version:
    * 2.6.11-gentoo-r5
    * Checking for suitable kernel configuration options
    * ALSA is already compiled into the kernel.
    * Please check to make sure these options are set correctly.
    * Once you have satisfied these options, please try merging
    * this package again.

    !!! ERROR: media-sound/alsa-driver-1.0.8 failed.
    !!! Function check_extra_config, Line 439, Exitcode 0
    !!! Incorrect kernel configuration options
    !!! If you need support, post the topmost build error, NOT this status message.

    ...?
    [edit]
    This is from my kernel config file:
    # Sound
    #
    CONFIG_SOUND=y

    #
    # Advanced Linux Sound Architecture
    #
    CONFIG_SND=y
    CONFIG_SND_TIMER=y
    CONFIG_SND_PCM=y
    CONFIG_SND_SEQUENCER=y
    # CONFIG_SND_SEQ_DUMMY is not set
    CONFIG_SND_OSSEMUL=y
    CONFIG_SND_MIXER_OSS=y
    CONFIG_SND_PCM_OSS=y
    CONFIG_SND_SEQUENCER_OSS=y
    # CONFIG_SND_VERBOSE_PRINTK is not set
    # CONFIG_SND_DEBUG is not set

    ..i think that matters...
    [edit]

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Make sure alsa is compiled as modules, and then run this:
    Code:
    emerge alsa-utils
    And then finally:
    Code:
    alsaconf
    That should take care if everything for you. By the way, with the mouse wheel, add this to the xorg.conf file under the mouse section:
    Code:
        Option "ZAxisMapping" "4 5"

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    I will try that .....
    but as far as the mouse i DID get it working...
    but besides the zaxismapping option it also required that the protocol option be changed from
    PS/2 to IMPS/2.
    [edit]
    OK! So it was kind of a mix of the two suggestions.... i emerged alsa-utils
    then used the alsamixer command and unmuted everything... followed by alsactl store

    But anyway works now. On to the printer then I'll have everything taken care of.

    Thanks so much for the help.
    [edit]

  7. #6
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by sw4qw
    I will try that .....
    but as far as the mouse i DID get it working...
    but besides the zaxismapping option it also required that the protocol option be changed from
    PS/2 to IMPS/2.
    [edit]
    OK! So it was kind of a mix of the two suggestions.... i emerged alsa-utils
    then used the alsamixer command and unmuted everything... followed by alsactl store

    But anyway works now. On to the printer then I'll have everything taken care of.

    Thanks so much for the help.
    [edit]
    Code:
    rc-update add alsasound default
    This will store/load your mixer levels for you upon reboot. Ahh...the power of init scripts.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  8. #7
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    As far as I know, just doing alsactl store will do that much... but I didn't know that you could do it that way

  9. #8
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    205
    Wow thanks guys you kick ass, this will help me on my quest to enlightenment, in 5 minutes when I shall cast my inferno on the ntfs partition, and the debian ext3 partition and install Gentoo and FreeBSD!!! muahaha...
    Ma homeboy is Jesus himself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •