Find the answer to your Linux question:
Results 1 to 4 of 4
hey everyone i have 2 problems with my current Gentoo linux 2004.3 linux installation, i have two current problems i was hoping i could get help with 1. This error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7

    Random Gentoo problem Please help ASAP


    hey everyone
    i have 2 problems with my current Gentoo linux 2004.3
    linux installation, i have two current problems i was hoping i could get help
    with
    1. This error i recieve at startup
    "Some local filesystem failed to mount" (gee thats specific :P)
    2. I cant get internet access, and need to configure the nameserver and the gateway, this is a comp receiving shared net access from windows comp

    i would be extremely greatful if anyone could be of assistance

    exeqt 05'

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    the first problem is probably not that important, take a look at the /etc/fstab file which contains a list of all filesystems which will be mounted at boot, if there is one in that that does not exist or for example the cdrom might be listed with "auto" (mount automaticaly at boot time) then that would cause that error - not to serious though as long as the system boots up!

    the second problem is a bit harder, i dont use windows directly but i belive you can set up ICS (internet connection sharing) under windows and then run a DHCP client under linux to automaticaly detect and configure the ip/DNS/gateway on linux.

    If you know the nameserver/gateway/IP that you want the linux comp to use then you can set that up with the ifconfig and route command (ifconfig not ipconfig)

    "ifconfig eth0 192.168.0.1 up" "route add default gw 192.168.0.0" and the nameserver would go into /etc/resolv.conf

    Hope this is of some help!

  3. #3
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    You probably use DHCP for your internet settings. Go into Gentoo then, as root, use

    Code:
    nano -w /etc/init.d/net
    and change the line that says eth0 (or whatever your connection should be) to say

    Code:
    eth0="dhcp
    That should do it, hope it helps.
    --Dachnaz [Fuzzy Llama]

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    thanks you guys for helping me
    ive managed to get everything working and compared to the configuration
    i had problems with when i posted here, this is skittles :P
    gentoo is powerful but can be quite painstaking if you dont know nix
    quite knowledgeably beforehand

    once again thanks

    exeqt
    FortifiedWare 05'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •