Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
After a long and arduous install lasting two and a half days (God knows why, i only did a stage 3), I finally have a working gentoo system with a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29

    sound in gentoo


    After a long and arduous install lasting two and a half days (God knows why, i only did a stage 3), I finally have a working gentoo system with a working gnome.

    I have read that the difficulty in gentoo arises at the install stage. With this heartening thought in mind (after all, the install wasn't *that* difficult), I set about trying to configure my new system.

    I have run against more hurdles than I can count now. I will list my two main problems.

    X

    X won't start with a xorg.conf file present, no matter how i tweak it. So I'm running X without this config file, could someone let me know how X gets it config data in the absence of this file? If I know this I may be able to enter the correct settings to make X work with everything I want enabled. I have tried xorfcfg to no avail.

    SOUND.

    Sound does not work.

    I have a soundblaster live! sound card -> piece of junk now, but i can't afford anything better.

    I have looked at the alsa guide here:
    http://www.gentoo.org/doc/en/alsa-guide.xml ;
    and here:
    http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix

    I have Sound card support enabled in my kernel. I do not have specifically ALSA or OSS enabled as stated in the howto.

    # lspci | grep audio
    gives:
    0000:02:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)

    I have tried unmerging and remerging all the relevant audio packages and updating my config files in /etc, using etc-update and added the line:
    alias snd-card-0 snd-EMU10k1
    trying both emu10k1 and EMU10k1 (both are used depending on where you look)

    updating the modules and starting alsasound yield nothing.

    I have tried turning up the volumes in the gnome software mixer. The speaker icon in the upper-right corner of the screen has a red line through it. hovering the mouse over this icon yields the message "No audio device" left-clicking on it gives the message "Couldn't open mixer device /dev/sound/mixer"

    If someone can give me any hint at solving these puzzles I'd be very appreciative, in fact, had i any money I'd email them a bottle of whisky for their troubles.

    Thanks for your time,
    Dave.

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    Oklahoma
    Posts
    38
    Hmm... don't know what to make of your X woes.

    But to get sound (on Slack) I had to enable alsa and alsa oss modules in the kernel to get sound. Don't know if this will help you or not.

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Remember to compile alsa and the alsa-driver as modules, if not alsaconf wont work. Then type in this as root:
    Code:
    emerge alsa-utils
    alsaconf
    Also remember to unmute the channels, do this with "gnome-alsamixer" or "alsamixer" or another mixer. Also make sure your user is in the "audio"-group.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    if you try to start x and it crashes with your xorg.conf file, you will see which errors caused it to crash, the most common seem to be "no core pointer" your mouse is configured incorrectly, and "no screens found" which could be many things but is usually the vertical and horizontal monitor sync settings being set up incorrectly. The last time I set up an xorg.conf file I kept getting an error and I studied my file for hours before I realized that I had a typo, in one of my "EndSection"s I left out a letter...that was it. But usually these small errors are shown as parsing errors and it will even display which line the parsing error is on...so if you could post which messages you see when x crashes because of your xorg.conf we can help you figure it out [/i]
    Operating System: GNU Emacs

  6. #5
    Linux User
    Join Date
    Dec 2004
    Location
    Speed School of Engineering
    Posts
    267
    Nevermind this post, moved it to a separate thread

  7. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    not exactly enough to go on, what have you tried? Have you followed the gentoo alsa guide? Have you looked up your card on the alsa matrix, have you put it in make.conf, have you added the module to a modulized kernel? Have you ran alsaconf? Have you unmuted the default channels?

    like I said you should be a bit more specific...and tell us what you have and haven't done
    Operating System: GNU Emacs

  8. #7
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    OK, well, I have a working xorg.conf, thanks for the info Genesus. Sync and mouse settings were wrong.

    I'm still struggling with sound though.

    When I compiled my kernel I *did* compile in ALSA support and also support for my sound card as a module.

    I'm fairly sure that my card requires emu10k1 (not EMU10k1), however:
    # /etc/init.d/alsasound restart
    gives
    * WARNING: you are stopping a boot service.
    * Storing ALSA Mixer Levels...
    /usr/sbin/alsactl: save_state:1194: No soundcards found... [ !! ]
    * Unloading ALSA... [ ok ] * Unloading ALSA modules... [ ok ] * Loading ALSA modules...
    * Loading: snd-card-0...
    FATAL: Module EMU10k1 not found. [ !! ]
    * ERROR: Failed to load necessary drivers [ ok ] * Restoring Mixer Levels...
    * No mixer config in /etc/asound.state, you have to unmute your card! [ ok ]

    you can see that module EMU10k1 is trying to start.

    As described in http://gentoo-wiki.com in the alsa section I have added the line ALSA_CARDS="emu10k1" to /etc/make.conf and set all the aliases properly in /etc/modules.d/alsa.

    I have run modules-update yet attempting to restart alsasound gives the above message. Why is this module trying to load rather than the desired emu10k1?

    Thanks again,
    Dave.

  9. #8
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    before you unmute you should run alsaconf, have you tried that?
    Operating System: GNU Emacs

  10. #9
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    yeah i've tried alsaconf .. it exits with same output as shown above

  11. #10
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    its the same module. try modprobe emu10k1 before you do /etc/init.d/alsasound start

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •