Find the answer to your Linux question:
Results 1 to 2 of 2
I am new to Gentoo, and want to get it set up because i am under the impression that it is the unicorn of distros.. and have always stuck to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    Atlanta, GA
    Posts
    3

    mounting before filecopy.


    I am new to Gentoo, and want to get it set up because i am under the impression that it is the unicorn of distros.. and have always stuck to just using a GUI installer (with the exception of BSD) in the past. I'm trying to get my command line installation skills down, and ran into a few problems.

    Well, I'm working on installing Gentoo 2005.0 on one of my extra hard drives.. having a little issue in mounting the partitions soon after creation and formatting. I'm choosing to go the stage 2 route

    I run through the fdisk, get everything set like this:
    dev/hda1 bootable 32M linux
    dev/hda2 768M linux swap
    dev/hda3 remainder linux

    then i run the formatting commands:

    mke2fs /dev/hda1
    mke2fs -j /dev/hda3
    and then my swapspace
    mkswap /dev/hda2

    everything works fine, no errors.

    then when i go to swapon /dev/hda2 i get errors (already in use kinda message).
    i figured wtf, and went on to try and mount my other partitions..

    mount -t ext3 /dev/hda3 /mnt/gentoo (same type message)
    mkdir /mnt/gentoo/boot
    mount /dev/hda1 /mnt/gentoo/boot(device is busy message)

    so I'm stuck, RTFM with nothing surfacing to help me.

    ANYONE that wishes to respond with help, PLEASE DO.

    my AIM and such are listed, till then.. I'm blowin' in doze. :-/

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    post the output of:
    Code:
    cat /etc/mtab
    that will tell you what partitions are mounted. also you might want to try rebooting... as fdisking will sometimes require this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •