Find the answer to your Linux question:
Results 1 to 9 of 9
As soon as I heard that Gentoo 2005.0 was out, I did an emerge -u system and walked away. When I came back, I found, much to my dismay, that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    16

    Problems running emerge -u system


    As soon as I heard that Gentoo 2005.0 was out, I did an emerge -u system and walked away. When I came back, I found, much to my dismay, that it failed about 41 packages in, on a package named file-4.12 with this error

    Code:
    ../src/file -C -m magic
    WARNING: type lestring16 >0 Description: %15.15s invalid
    lt-file: could not find any magic files!
    make[2]: *** [magic.mgc] Error 255
    make[2]: Leaving directory `/var/tmp/portage/file-4.12/work/file-4.12/magic'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/var/tmp/portage/file-4.12/work/file-4.12'
    make: *** [all] Error 2
    As I sat there scratching my head, I wondered, What the hell is a magic file?

    Thanks in advance

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    try:
    Code:
    emerge -uD world
    Could be a problem with deep dependencies.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Agressive optimalisationflags (for example "-O3") in /etc/make.conf may also lead to insucsessfull builds. But try sdousleys method first.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    16
    Thanks very much for the replies. I tried both your suggestions, but neither of them worked. Running emerge with -uD seemed to skip over the file package to do some other (gcc, binutils, many other) only to come back to it later and fail. Got any other suggestions?

    Thanks

  6. #5
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    could you post your make.conf?
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    16
    Here's my make.conf. If it might help, I installed this system using a stage 3 from 2004.3:

    # These settings were set by the catalyst build script that automatically built this stage
    # Please consult /etc/make.conf.example for a more detailed example
    CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
    CHOST="i686-pc-linux-gnu"
    CXXFLAGS="${CFLAGS}"
    USE="gtk gnome alsa dvd truetype expat xml java ipv6 pda gstreamer
    -xinerama -kde -qt -oss"

  8. #7
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    could you please post more of the error message (10 lines or so above/below what you allready posted) also please post the output of "emerge -vut system"

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    16
    Thanks for the help, but I've got this taken care of. It turns out this is a known bug in Gentoo. The problem was a faulty magic file in the source tarball.

  10. #9
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    OFF TOPIC: you should add the CFLAG '-pipe ' to your cflags it makes the compiles go a bit faster
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •