Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 27
That's what I did....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110

    That's what I did.

  2. #12
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Emerge "devfsd", not "devfs"... Sorry, just a typo.

  3. #13
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    lol, thanks

  4. #14
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    aagh. When I
    Code:
    emerge devfsd
    it tries to get it from the net, even though I haven't got the net, and devfsd is in /usr/portage/distfiles

  5. #15
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Boot up the livecd, mount the partitions as you did when you installed, chroot into the enviroment and at last emerge devfsd.

  6. #16
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    That's what I tried - I think I'll try re-installing, possibly from a newly burnt disk - the one I use is a bit dirty.

  7. #17
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Ok... Good luck on the next attempt, I know you'll get it working at last!

  8. #18
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    Thanks! I hope so

  9. #19
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    Odd, I managed to succesfully emerge devfsd (I downloaded the file on another computer and copied it to /usr/portage/distfiles first), but I still get the error . Oh well, I'll do the re-install I was going to do...

  10. #20
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    110
    ...Nope, still didn't work. I get the same error as last time when I try to boot. This is what I get:
    Code:
    >> Mounting filesystems
    mount: Mounting devfs on /dev failed: No such device
    Error opening file: ".devfsd" No such file of directory
    >>Determining root device...
    >> Block device /dev/hda9 is not a valid root device...
    >> The root block device is unspecified or not detected.
    Please specify a device to boot, or "shell" for a shell...
    boot() ::
    Please help, this is my third install and it hasn't worked!

    If it helps, the only other line that comes up as Gentoo boots that might help is:
    Code:
    :: Scanning for sata-vitesse... module not found
    but since I have a standard IDE harddrive, I doubt this is connected.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •