Find the answer to your Linux question:
Results 1 to 6 of 6
Hey all, I've got the D-Link DWL 122 USB Wireless card, and getting it to work on Linux was a pain, but after I figured out what was going on, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035

    Tutorial: DLink DWL 122 on Gentoo


    Hey all,
    I've got the D-Link DWL 122 USB Wireless card, and getting it to work on Linux was a pain, but after I figured out what was going on, I got it to work on gentoo fairly easily. Here's what you need:

    -2.6.x kernel
    -linux-wlan-ng-0.2.1-pre17 (it's not in the distfiles on the LiveCD, so you'll have to get it on your Gentoo Box somehow)
    Place the linux-wlan-ng tarball in /usr/portage/distfiles, and run:
    Code:
    USE="usb -pci" emerge '=linux-wlan-ng-0.2.1-pre17'
    Plug in the card
    Code:
    modprobe prism2_usb
    Code:
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    /etc/init.d/wlan start
    dhcpcd wlan0
    and you should be set.

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    downloaded the latest ebuild from bugs.gentoo.org - it was up to pre26 today.

    Code:
    root@tyndale linux-wlan-ng # modprobe prism2_usb
    root@tyndale linux-wlan-ng # tail /var/log/messages 
    ...
    May 18 20:34:36 tyndale prism2usb_init: prism2_usb.o: 0.2.1-pre26 Loaded
    May 18 20:34:36 tyndale prism2usb_init: dev_info is: prism2_usb
    May 18 20:34:36 tyndale usbcore: registered new driver prism2_usb
    root@tyndale linux-wlan-ng #
    pluged in the card and got

    Code:
    May 18 20:36:58 tyndale usb 1-1.1: new full speed USB device using uhci_hcd and address 5
    May 18 20:36:58 tyndale usb 1-1.1: device descriptor read/64, error -71
    May 18 20:36:58 tyndale usb 1-1.1: device descriptor read/64, error -71
    May 18 20:36:58 tyndale usb 1-1.1: new full speed USB device using uhci_hcd and address 6
    May 18 20:36:58 tyndale usb 1-1.1: device descriptor read/64, error -71
    May 18 20:36:58 tyndale usb 1-1.1: device descriptor read/64, error -71
    but the next command fails.

    Code:
    wlanctl-ng lnxreq_ifstate ifstate=enable 
    The cmd 'ifstate=enable' is invalid
    looks like i need kernel options

    Code:
    root@tyndale NSLU2 # /etc/init.d/wlan restart 
     * Shutting Down WLAN Devices...
    wlanctl-ng: No such device                                                [ ok ]
     * Starting WLAN devices...
    FATAL: Module wlan0 not found.
    Error: Device wlan0 does not seem to be present.
    Make sure you've inserted the appropriate
    modules or that your modules.conf file contains
    the appropriate aliase(s).
    wlanctl-ng: No such device
    error: Autojoin indicated failure!                                        [ ok ]
    root@tyndale NSLU2 #

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    two more things. first, i plugged the card into the linux box (skipped the usb hub) result is more stuff in /var/log/messages.

    second was to put s 'wlan0' in that command
    Code:
    root@tyndale linux # wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    \message=lnxreq_ifstate
      ifstate=enable
      resultcode=success
    also put

    Code:
    alias wlan0 prism2_usb
    in /etc/modules.d/aliases and did a modules-update.

    strangely the init script is failing on the enable command which works from the command line!

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    sorry I f**ked up on the tutorial. I forgot a couple command line deals.

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    I deleted the firmware download part from /etc/wlan/shared just before it does the enable and that let it get through the /etc/init.d/wlan start script.

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    my last step was to

    ln -s /etc/init.d/net.eth0 /etc/init.d/net.wlan0

    and

    /etc/init.d/net.wlan0 restart

    (I had also edited /etc/conf.d/net to setup wlan0)

    I am now posting via my DWL-122!

    yay

    matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •