Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
What a bummer, it emerged 8 of 17 and somehow lost the internet connection, it couldn't resolve the names anymore, or something like that. I am totally baffled by that, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242

    What a bummer, it emerged 8 of 17 and somehow lost the internet connection, it couldn't resolve the names anymore, or something like that.
    I am totally baffled by that, because I was still surfing the net using links.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  2. #12
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    This is just weird.
    Once I chroot into my Gentoo system, I ca no longer use the net.
    I brought up links before I chrooted, so in this terminal, I can access the net. I am typing this from the F2 terminal(livecd). If I hit Alt+F1, where I have chrooted into the system, I can't get on the internet.

    This problem started when I tried to "emerge livecd-tools". 8 of 17 were succesfully emerged.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #13
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Try re-copying /etc/resolv.conf over to /mnt/gentoo/etc/reslov.conf, and then chroot over again...

  4. #14
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    That worked insofar as I have internet when I use the livecd and chroot into the system.
    When I rebooted without the livecd. I typed "net-setup eth0" NOTHING returned, it just went back to my prompt.
    So, I went through the modprobe 8139too and net.eth0 start routine, and that didn't help. It still could not bring up eth0 via dhcp.

    All this time, I am working under the assumption that 8139too or 8139cp is the module for my Realtek 8139 ethernet card. Is this the correct module?
    Is there a way to find out which module I should be using?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  5. #15
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Yes, do a "lsmod" before you changeroot to see which modules the livecd loaded for you... You are also sure you have emerged "dhcpcd", if not it won't be able to recieve an ip-adress with dhcp...

  6. #16
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I am 99% sure I emerged dhcpcd. I have reinstalled quite a few times.

    When I look in /etc/conf.d/net, I see iface_dhcp=eth0, iface_dhcpcd="..."

    When I did the lsmod from the livecd. It loaded module 8139too, used by 0,
    It loaded module mii, used by 8139too
    So, I put the mii in /etc/module.autoload.d, did the modules-update, and rebooted. No internet
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  7. #17
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Change iface_dhcpcd="..." to iface_dhcpcd="-HDN"

  8. #18
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Actually it was "iface_eth0=dhcp" and "dhcpcd_eth0="..."".
    I changed the second one to "dhcpcd_eth0="HDN"", but that didn't do anything.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  9. #19
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Remember the "-" in front of HDN...

  10. #20
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    This is what my /etc/conf./net file looks like.
    Code:
    # /etc/conf.d/net:
    # $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/net,v 1.7 2002/11/18 19:39:22 azarah Exp $
    
    # Global config file for net.* rc-scripts
    
    # This is basically the ifconfig argument without the ifconfig $iface
    #
    #iface_eth0="192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0"
    #iface_eth1="207.170.82.202 broadcast 207.0.255.255 netmask 255.255.0.0"
    
    # For DHCP set iface_eth? to "dhcp"
    # For passing options to dhcpcd use dhcpcd_eth?
    #
    iface_eth0="dhcp"
    dhcpcd_eth0="_HDN"
    
    # For adding aliases to a interface
    #
    #alias_eth0="192.168.0.3 192.168.0.4"
    
    # NB:  The next is only used for aliases.
    #
    # To add a custom netmask/broadcast address to created aliases,
    # uncomment and change accordingly.  Leave commented to assign
    # defaults for that interface.
    #
    #broadcast_eth0="192.168.0.255 192.168.0.255"
    #netmask_eth0="255.255.255.0 255.255.255.0"
    
    
    # For setting the default gateway
    #
    #gateway="eth0/192.168.0.1"
    I must have configured it wrong.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •