Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
When I first boot up, I get a message saying that "netmount was not started." When I do "lsmod", I don't see the module for my Realtek Ethernet card. It ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242

    Netmount does not start


    When I first boot up, I get a message saying that "netmount was not started."
    When I do "lsmod", I don't see the module for my Realtek Ethernet card. It should be 8139too I believe. The only hing that comes close is 8139cp.

    If I do "modprobe 8139too" or modprobe 8139cp" then "/etc/init.d/net.eth0 start" I get "bringing up eth0 via dhcp", but there are 2 exclamation marks to the right of the screen.

    So, I am thinking that I am missing the correct module. How can I go about getting the correct module?

    Your help is appreciated.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Three possible ways of trying:

    1) Try emerging "livecd-tools" and use "net-setup" (same utility as the gentoo-livecd uses) to setup the internet for you

    __OR__

    2) Try adding the driver to "/etc/modules.autoload.d/kernel-2.6" and run "modules-update"

    __OR__

    3) Try building the as built-in (not a module)

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    The first suggestion is not an option. I can't emerge anything without access to the net. Unless there is a way to point it at the livecd.

    Option 2, how do I add something? Do I just "add /etc/modules.autoload.d/kernel-2.6"? Or is there something else I have to do.

    Option 3, I was really hoping to avoid recompiling the kernel.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    1) I meant on the livecd, after copying resolv.conf and chroot'ing. Or did you not get into the net on the livecd neither? Then try net-setup on the livecd.

    2) You open the file with a text-editor and simply add the module-name. Then run modules-update (after chroot'ing ofcourse)

    3) If you compiled the kernel manually, it won't take that long time since many modules etc. are allready compiled.

  6. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Just to make sure I have this correct.
    I boot with the livecd(where I do have internet access)
    I do "chroot /mnt/gentoo /bin/bash"
    then nano -w /etc/modules.autoload.d/kernel-2.6 then add 8139too, save my work
    Then "modules-update" ENTER
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  7. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Yup, as long as you have the driver-module installed (probably compiled with the kernel) that should work fine. Just to make sure, here is a quote from gentoo.org handbook:
    ld list the modules you want automatically loaded in /etc/modules.autoload.d/kernel-2.4 (or kernel-2.6). You can add extra options to the modules too if you want.

    To view all available modules, run the following find command. Don't forget to substitute "<kernel version>" with the version of the kernel you just compiled:

    Code Listing 27: Viewing all available modules

    # find /lib/modules/<kernel version>/ -type f -iname '*.o' -or -iname '*.ko'

    For instance, to automatically load the 3c59x.o module, edit the kernel-2.4 or kernel-2.6 file and enter the module name in it.

    Code Listing 28: Editing /etc/modules.autoload.d/kernel-2.4

    (Example for 2.4 kernels)
    # nano -w /etc/modules.autoload.d/kernel-2.4

    Code Listing 29: /etc/modules.autoload.d/kernel-2.4 or kernel-2.6

    3c59x

  8. #7
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Option 2 didnt work. I couldn't chroot into gentoo.
    When I tried "chroot /mnt/gentoo /bin/bash"
    I was told no such file or directory /bin/sh
    I tried "chroot /mnt/gentoo /bin/bash"
    after cd /mnt/gentoo, same error
    So, I must not be using the chroot command correctly
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  9. #8
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    You remembered to mount the partititons before chroot'ing? And you also made sure you haven't allready chroot'ed? If so, it should work, it does here...

  10. #9
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    DUH, That might help
    Thanks
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  11. #10
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Well, that didn't work. After rebooting, eth0 still wouldn't come up. So, I tried doing that /etc/init.d way, and that didn't work. So, I rebooted with the livecd and I am currently emerging the livecd-tools. I have a good feeling about this one.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •