Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
Hi, I'm having trouble getting my sound card working on Gentoo 2005.0 (1.4.16). It's an Intel integrated sound card on a Dell Dimension 4700. lspci says: Code: 0000:00:1e.2 Multimedia audio ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035

    Gentoo Sound Card Trouble


    Hi, I'm having trouble getting my sound card working on Gentoo 2005.0 (1.4.16). It's an Intel integrated sound card on a Dell Dimension 4700.
    lspci says:
    Code:
    0000:00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
    I've googled this day and night, and I just can't get it to work...any ideas?

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Have you checked the gentoo alsa handbook, its pretty thorough? If you have your kernel setup correctly you just need to look up your cards driver in the alsa card matrix, modprobe it, and then add the name of the driver to your make.conf.

    The guide is pretty well written up, you may have to emerge additional drivers or alsa apps though.

    Gentoo Alsa Handbook[/url]
    Operating System: GNU Emacs

  3. #3
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    heh you can try in the kernel this i found this listed on google for this card even though it dont list the correct chipset's in the menuconfig
    Code:
    -> Device Drivers
      -> Sound
        -> Advanced Linux Sound Architecture
           -> PCI devices=20
               Intel/SiS/nVidia/AMD MC97 
    or
    < > Intel i8x0/MX440, SiS 7012; Ali 5455; NForce Audio; AMD768/8111 &#40;NEW&#41;
    and if this is a modem too then this might also be needed or not
    Code:
    < > Intel i8x0/MX440; SiS 7013; NForce; AMD768/8111 modems &#40;EXPERIMENTAL&#41; &#40;NEW&#41;
    the above is for kernel alsa if you are using the alsa-drivers then checkonly sound support and nothing in alsa or oss and put
    Code:
     ALSA_CARDS="intel8x0"
    in /etc/make.conf then emerge alsa-driver

    that's my 2cents
    also check that you dont have anything checked at all in the OSS section under sound in the kernel ...that will block alsa from loading

    this is from the alsa matrix: description: "Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455"

    i think i have the same chipset an my compaq lappie ...yeah i do...and the last thing to do is run alsaconf and it will set up the snd driver in /etc/modules.d/alsa and modules-update and all the other little things
    also dont forget to unmute your speakers!
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Nope. it's still buggered.

  5. #5
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    lol.... time for a diffrent snd card
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #6
    Just Joined!
    Join Date
    Apr 2005
    Location
    UK
    Posts
    25

    Re: Gentoo Sound Card Trouble

    Quote Originally Posted by lakerdonald
    Hi, I'm having trouble getting my sound card working on Gentoo 2005.0 (1.4.16). It's an Intel integrated sound card on a Dell Dimension 4700.
    lspci says:
    Code:
    0000&#58;00&#58;1e.2 Multimedia audio controller&#58; Intel Corporation 82801FB/FBM/FR/FW/FRW &#40;ICH6 Family&#41; AC'97 Audio Controller &#40;rev 03&#41;
    I've googled this day and night, and I just can't get it to work...any ideas?
    You got the same as me, I did get it working once by intergrating ALSA into the kernel, I then installed e17 and it got screwed up.

  7. #7
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Tried both ways.

  8. #8
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    what is the output of your /etc/modules.d/alsa file:

    do you have the relevant snd-card0 portion pointing the the driver of your card?

    mine looks like this for the cs46xx driver for my card:

    # ALSA portion
    alias char-major-116 snd
    # OSS/Free portion
    alias char-major-14 soundcore

    ##
    ## IMPORTANT:
    ## You need to customise this section for your specific sound card(s)
    ## and then run `update-modules' command.
    ## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
    ##
    ## ALSA portion
    alias snd-card-0 snd-cs46xx
    ## alias snd-card-1 snd-ens1371
    ## OSS/Free portion
    alias sound-slot-0 snd-cs46xx
    ## alias sound-slot-1 snd-card-1
    ##

    # OSS/Free portion - card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    ## OSS/Free portion - card #2
    ## alias sound-service-1-0 snd-mixer-oss
    ## alias sound-service-1-3 snd-pcm-oss
    ## alias sound-service-1-12 snd-pcm-oss

    alias /dev/mixer snd-mixer-oss

    -------------
    If you change this just type: modules-update. then try amixer and see if you get any output: if you do then card should be working then just umute with alsamixer command.

    Sorry if you tried all of this and this is repetitive but I screw up little things all the time. good luck. Also...I did all this stuff and wasn't getting any sound and was very confused but I realized that my thinkpad has sound buttons on the keyboard which are hardwired and need to be unmuted regardless of any alsa stuff. I just hit the unmute button at top of keyboard and all my problems solved...even though it took me 2 hours of messing with stuff to try the simplest of all solutions.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  9. #9
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    oh yeah make sure you have started alsa. /etc/init.d/alsasound start.

    then add to startup. rc-update add alsasound boot.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  10. #10
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Sorry I've tried all of that :/
    but using the alsa-driver ebuild, i get this when trying:
    Code:
    #insmod snd-card-0
    
    WARNING&#58; Error inserting snd &#40;/lib/modules/2.6.7-gentoo-r11/alsa-driver/acore/snd.ko&#41;&#58; Input/output error
    WARNING&#58; Error inserting snd_timer &#40;/lib/modules/2.6.7-gentoo-r11/alsa-driver/acore/snd-timer.ko&#41;&#58; Unknown symbol in module, or unknown parameter &#40;see dmesg&#41;
    WARNING&#58; Error inserting snd_pcm &#40;/lib/modules/2.6.7-gentoo-r11/alsa-driver/acore/snd-pcm.ko&#41;&#58; Unknown symbol in module, or unknown parameter &#40;see dmesg&#41;
    WARNING&#58; Error inserting snd_ac97_codec &#40;/lib/modules/2.6.7-gentoo-r11/alsa-driver/pci/ac97/snd-ac97-codec.ko&#41;&#58; Unknown symbol in module, or unknown parameter &#40;see dmesg&#41;
    FATAL&#58; Error inserting snd_intel8x0 &#40;/lib/modules/2.6.7-gentoo-r11/alsa-driver/pci/snd-intel8x0.ko&#41;&#58; Unknown symbol in module, or unknown parameter &#40;see dmesg&#41;
    
    #dmesg
    
    1.0.8/work/alsa-driver-1.0.8/acore/sound.c&#58;352&#58; unable to register native major device number 116
    snd_mixer_oss&#58; Unknown symbol snd_compat_kcalloc
    snd_mixer_oss&#58; Unknown symbol snd_verbose_printk
    ALSA /var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore/sound.c&#58;352&#58; unable to register native major device number 116
    snd_timer&#58; Unknown symbol snd_compat_kcalloc
    snd_timer&#58; Unknown symbol snd_verbose_printk
    snd_pcm&#58; Unknown symbol snd_compat_kcalloc
    snd_pcm&#58; Unknown symbol snd_verbose_printk
    snd_ac97_codec&#58; Unknown symbol snd_compat_kcalloc
    snd_ac97_codec&#58; Unknown symbol snd_verbose_printk
    snd_intel8x0&#58; Unknown symbol snd_ac97_pcm_close
    snd_intel8x0&#58; Unknown symbol snd_ac97_resume
    snd_intel8x0&#58; Unknown symbol snd_compat_kcalloc
    snd_intel8x0&#58; Unknown symbol snd_ac97_pcm_open
    snd_intel8x0&#58; Unknown symbol snd_ac97_set_rate
    snd_intel8x0&#58; Unknown symbol snd_ac97_update_bits
    snd_intel8x0&#58; Unknown symbol snd_ac97_mixer
    snd_intel8x0&#58; Unknown symbol snd_ac97_bus
    snd_intel8x0&#58; Unknown symbol snd_verbose_printk
    snd_intel8x0&#58; Unknown symbol snd_ac97_pcm_double_rate_rules
    snd_intel8x0&#58; Unknown symbol snd_ac97_suspend
    snd_intel8x0&#58; Unknown symbol snd_ac97_get_short_name
    snd_intel8x0&#58; Unknown symbol snd_ac97_pcm_assign
    snd_intel8x0&#58; Unknown symbol snd_ac97_tune_hardware
    ALSA /var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore/sound.c&#58;352&#58; unable to register native major device number 116
    snd_mixer_oss&#58; Unknown symbol snd_compat_kcalloc
    snd_mixer_oss&#58; Unknown symbol snd_verbose_printk
    ALSA /var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore/sound.c&#58;352&#58; unable to 
    ...
    ...
    ...

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •