Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi all! It's me again. I now understand why Gentoo is billed as a several-day-long install operation. Well, let me give you an update: I can now boot into Gentoo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252

    ndiswrapper modprobe issue


    Hi all! It's me again. I now understand why Gentoo is billed as a several-day-long install operation.

    Well, let me give you an update:

    I can now boot into Gentoo and operate in there. Currently, though, I'm in Knoppix, with Gentoo open in a terminal.

    I now need to set up my ndiswrapper so I can emerge from the Gentoo itself. This is important for letting me configure my X Server, requiring me to modify my config files as things turn up, and once all is done, finally emerge GNOME.

    Now then, I have emerge'd ndiswrapper, and have properly installed the inf file. However, the problem comes when I run "modprobe ndiswrapper". This gives me the old "Improper format" error message. When I run "dmesg wlan0", I get the following message (I wrote a Perl script to extract it, so it was a learning experience!):

    Code:
    ndiswrapper: version magic '2.6.11-gentoo-r6 SMP preempt PENTIUM4 gcc-3.3' should be '2.6.11-gentoo-r6 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
    The difference here involves the 4KSTACKS. When I originally emerge'd ndiswrapper, I was told that because I had 4KSTACKS enabled, it would not work. So I removed it, and now I am getting this stupid error message.

    I have tried running "modules-update", and this has done nothing. I also tried unmerging ndiswrapper and re-emerging it. It still gives me this error.

    If anyone has any ideas, feel free to share. Again, thank you all.

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    An update:

    Alrighty, I think I've figured the problem. When I run "uname -v", I'm running a kernel compiled at:

    16:12:29

    However, the kernel image that GRUB is booting was created at:

    18:58

    Furthermore, my ndiswrapper is named ending with the -r3 extension, while my kernel is r6.

    I've tried re-installing GRUB several times, but it still boots to a kernel 2 hours early. What am I doing wrong?

    Also, as another note, this is the error message I get when I modprobe ndiswrapper:

    Code:
    FATAL: Error inserting ndiswrapper (/lib/modules/2.6.11-gentoo-r6/misc/ndiswrapper.ko): Invalid module format
    I need to go to sleep, but I'll check tomorrow. Thanks again for all your help!

  3. #3
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    did u remove the 4kstacks from the kernel or from the scrypt?
    the proper thing to of done here would of unchecked 4kstacks in the kernel and checked 8kstacks

    make shure the date set correctly and if not then re set it

    recompile your kernel then re-emerge ndiswrapper and all should be wess and you shouldnt need to set it up again(and remember that when u recompile the kernel to a new version you need to re-emerge ndiswrapper)
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  4. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    I unchecked the 4KSTACKS in the kernel. There was no 8KSTACKS option that I can see; I believe that is the default.

    As far as date, there is something a little funky going on; my Gentoo time is about 5 hours before my Knoppix time (as in 00:00:00 in Knoppix is 19:00:00 in Gentoo). However, either way, my Gentoo is showing the two things 2 hours apart.

    I also re-emerged ndiswrapper several times to no avail.

  5. #5
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    im a bit confused on the time thing what exactly is or inst going on on boot?
    and what dose that have to do with the ndiswrapper....if it is a seperate issue then start a new thread
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #6
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    The date relates because, after searching Gentoo forums, the problem seems to be caused by the booted kernel not being the compiled kernel. After checking the time of compilation of the running kernel, and the time of creation of the kernel image, I can see that they are different.

    I believe that my ndiswrapper was compiled to run with a non-4KSTACKS kernel, but that I am running a 4STACKS kernel. Hence the problem.


    I can't seem to correct this, so if you can think of something I missed, please let me know.

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    my suggestion would be to download the newest version of ndiswrapper from sourceforge. I believe that the newest version does not require the change in stacksize. And probably has fixed some other bugs. As with grub are you sure you have it pointed at right kernel source. When you change kernel are you copying over bzimage stuff.

    cp arch/i386/boot/bzimage /boot/kernel-2.6 ----this kernel-2.6 is what i have called my kernel and is what is listed in grub.conf
    cp System.map /boot/System.map

    I also have to mount /boot before I do this because i have it as noauto is fstab.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Updates:

    I got ndiswrapper working. For some reason, "make install" managed to fix the error. I also re-emerged ndiswrapper (though I had done it before also).

    I have switched over to LILO, as I was sick of GRUB. LILO is working fine.

    I have fixed my clock sync errors that were created with Knoppix.

    I have successfully emerged X and GNOME, and am typing this in Epiphany while Firefox is emerging.

    Thank you all so much for your help.

  9. #9
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    congrats... now remember that when you update your kernel to a new version remember to recompile the ndiswrapper or you will be in that same problem again
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  10. #10
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Cabhan, isn't it a great feeling when you type startx and X actually starts.

    Just curious, how long did it take to emerge Gnome.
    I took just under 9 hours to emerge KDE.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •