Find the answer to your Linux question:
Results 1 to 7 of 7
I edited /etc/X11/xorg.conf, and put "ZAxismapping" "4 5" in there. But my wheel mouse does not scroll. Any ideas?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242

    Wheel mouse


    I edited /etc/X11/xorg.conf, and put "ZAxismapping" "4 5" in there. But my wheel mouse does not scroll.
    Any ideas?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Perhaps you need a space?

    Code:
    "ZAxis Mapping" "4 5"
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    When you ran "xorgconfig", you also selected "IMPS/2" or "Auto", not "PS/2", right?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    It is fixed now, I don't know how.
    I was trying some different things.
    I tried "ZAxismapping" "6 7"=no change
    I tried "ZAxismapping" "3 4"=no butttons worked
    So, I went back to "ZAxismapping" ""4 5"
    And now it works.
    Maybe it just needed a full reboot, instead of just logging out into the Command line, and restarting X.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296

  7. #6
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    it didnt need a reboot :) the m should be capitalised too:

    "ZAxisMapping"

  8. #7
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    This is my /etc/X11/xorg.conf now. My wheel works great.

    Code:
     Identifier  "Mouse1"
        Driver      "mouse"
        Option "Protocol"    "IMPS/2"
        Option "Device"      "/dev/input/mice"
        Option "ZAxismapping" "4 5"
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •