Find the answer to your Linux question:
Results 1 to 8 of 8
This has been an annoyance that's been plaguing me for some time. When I boot my laptop (IBM X31) with Gentoo, it takes about 20 seconds to load the kernel. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! groovygroundhog's Avatar
    Join Date
    Mar 2005
    Location
    Arlington, VA
    Posts
    77

    Slow load on an IBM X31


    This has been an annoyance that's been plaguing me for some time. When I boot my laptop (IBM X31) with Gentoo, it takes about 20 seconds to load the kernel. This isn't a problem on my Latitude C800. Any ideas on what's going on?

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I would check to make sure that you only have necessary stuff enabled in your kernel. For instance you don't need drivers for x NIC if you have y. Simple things like this can slow you down.

    Without more specific 'error' messages or whatever its tough to tell. I have a T22 and its lightning fast so its not your computer.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined! groovygroundhog's Avatar
    Join Date
    Mar 2005
    Location
    Arlington, VA
    Posts
    77
    My kernel is very light weight but thanks for the suggestion. Is there anywhere you'd recommend looking for errors? Also, could there be an option I could set in Lilo?

  4. #4
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    maybe one suggestion would be to switch to grub. that is what i use it is easy and fast. Never used lilo though so I don't know about configuring that.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    Perhaps you are using genkernel and therefore initrd. if you are using initrd the boot time will be increased greatly. manualy recompile your kernel and remove the initrd

  6. #6
    Just Joined! groovygroundhog's Avatar
    Join Date
    Mar 2005
    Location
    Arlington, VA
    Posts
    77
    I'm nervous about switching to grub because I've had bad experiences. Also, this is my one windows computer and I can't risk losing the installation. I'm not running using a ramdisk nor did I use genkernel. It just takes forever to load the thing at boot time. I suppose I'll go back through my kernel and see if there's any junk I don't need in there. The filesystem on my boot partition is EXT3 if that matters. Could there be some integrity check it's doing on the kernel that I can override?

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    yeah that probably has something to do with it. Usually. as far as I know, boot partitions are ext2 because it does not have journaling. ext3 isn't bad for your boot but journaling and checking will slow things down.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Just Joined! groovygroundhog's Avatar
    Join Date
    Mar 2005
    Location
    Arlington, VA
    Posts
    77
    Can you go back from ext3 to ext2?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •