Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Having finally managed to install Gentoo (stage 3), I re-booted my PC. Gentoo seems to load fine until I hit some errors during the boot process. The first hint of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40

    Superblock corrupt?


    Having finally managed to install Gentoo (stage 3), I re-booted my PC. Gentoo seems to load fine until I hit some errors during the boot process. The first hint of trouble is a message saying the following;

    Starting devfsd...
    /sbin/rc: line 271: /sbin/devfsd: No such file or directory

    It then carries on, activating the swap and mounting the root filesystem. However, when it tries to check the filesystem I get the following;

    Checking root filesystem...
    fsck.ext3: No such file or directory while trying to open /dev/hdb3
    /dev/hdb3:
    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    Filesystem couldn't be fixed : (

    It then gives an option of logging in as root or a normal start, which just reboots the system.

    Any ideas? What have I done wrong? I seem to have got myself in a bit of a hole!

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    I had the same problem and just fixed it today:
    1)Boot up with LiveCD
    2)Mount /dev/sda1 on /mnt/gentoo (or /dev/hdb2 or /dev/hda4 wherever your / partition is)
    3)
    Code:
    mount /dev/sda1 /mnt/gentoo
    nano /mnt/gentoo/etc/fstab -w
    4)In your /etc/fstab, make sure that the fs type is right for /dev/ROOT and change /dev/ROOT to /dev/sda1 or whatever it is.
    Reboot. should work

  3. #3
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40
    Thanks for the reply lakerdonald.

    I have booted from the live CD and mounted the / partition as you suggested. However, I cannot see a problem. Here is the contents of my fstab file;

    /dev/hdb1 /boot ext2 defaults,noatime 1 2
    /dev/hdb2 none swap sw 0 0
    /dev/hdb3 / ext3 noatime 0 1

    none /proc proc defaults 0 0
    none /dev/shm tmpfs nodev,nosuid,noexec 0 0

    Any ideas on what I could try next?

    ps, glad you got the problem fixed for youself , just wish I could get mine working

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Ok...boot up your gentoo liveCD and run through the mounting and chrooting.

    Fire up nano and edit your /etc/conf.d/rc. Make the following variables look like this:

    Code:
    RC_DEVICES="udev"
    RC_DEVICE_TARBALL="yes"
    Also, make sure that you have udev emerged:

    Code:
    emerge udev
    And add hotplug to the default runlevel:

    Code:
    rc-update add hotplug default
    Exit chroot, umount and reboot. You should be good to go.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #5
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    I suggest you check and make sure that there is such a partition as hdb3, that it is ext3 and not ext2, reiserfs, fat32, ntfs, or whatever else it could possibly be. When I had errors such as this when Gentoo once reset my fstab, it was simply because it was trying to use the wrong filesystem.
    --Dachnaz [Fuzzy Llama]

  7. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Quote Originally Posted by Dachnaz
    I suggest you check and make sure that there is such a partition as hdb3, that it is ext3 and not ext2, reiserfs, fat32, ntfs, or whatever else it could possibly be. When I had errors such as this when Gentoo once reset my fstab, it was simply because it was trying to use the wrong filesystem.
    I seriously hope that he don't installed linux on an NTFS-partition as the NTFS-write support seems to be pretty bad

  8. #7
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    Truth. But who says hdb3 is his root partition? I'd sure as hell stick mine on hdaX... :P
    --Dachnaz [Fuzzy Llama]

  9. #8
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Truth. But who says hdb3 is his root partition?
    He does:
    Quote Originally Posted by gaz_dc
    /dev/hdb1 /boot ext2 defaults,noatime 1 2
    /dev/hdb2 none swap sw 0 0
    /dev/hdb3 / ext3 noatime 0 1

    none /proc proc defaults 0 0
    none /dev/shm tmpfs nodev,nosuid,noexec 0 0

  10. #9
    Just Joined! gaz_dc's Avatar
    Join Date
    Oct 2004
    Posts
    40
    Thanks for all the help.

    I have managed to solve the problem, but cannot for the life of me remember how! As soon as I figure out what I did differently the 10th or so time of trying I will post back with info.

    Thanks again

    Gaz

    ps, I wasn't trying to install a Linux distro on NTFS! HDa is my WinXP drive, HDb my drive for playing with different Linuxes (is that right? Or is the plural Lini?! I will stick to saying distros!)

  11. #10
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    This usualy happens when you have udev but dont uncheck 'devfs' in the kernel

    it is a nice monkeywrench in the system
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •