Find the answer to your Linux question:
Results 1 to 7 of 7
Hello, I've recently installed gentoo 2005.0 on my old x86 box, but when I try to boot into it (via lilo), after a short flurry of messages to the screen, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    4

    Can't boot after Gentoo 2005.0 install


    Hello,

    I've recently installed gentoo 2005.0 on my old x86 box, but when
    I try to boot into it (via lilo), after a short flurry of messages to the
    screen, the screen goes blitz full of random characters and the
    machine apparently crashes. If I boot with the install disk and chroot
    into the new installation, the last thing in /var/log/messages is
    the mounting of my disk paritions - that's it.

    What's the next step in the boot process and how do I fix it?

    Thanks,

    scot

    Code:
    # /etc/fstab: static file system information.
    # $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03
    :38 azarah Exp $
    #
    /dev/hde1      /dos        vfat     iocharset=iso8859-1,umask=0,codepage=850,noa
    uto  0 0
    /dev/hde2      /           ext3     defaults                        1 1
    /dev/hde3      none        swap     sw                              0 0
    /dev/hde5      /usr        ext3     defaults                        1 2
    /dev/hde6      /var        ext3     defaults                        1 2
    /dev/hde7      /tmp        ext3     defaults                        1 2
    /dev/hde8      /record     ext3     defaults                        0 2
    /dev/hde9      /usr/local  ext3     defaults                        1 2
    /dev/hde10     /opt        ext3     defaults                        1 2
    /dev/hde11     /home       ext3     defaults                        1 2
    /dev/hde12     /data       ext3     defaults                        1 2
    
    /dev/cdroms/cdrom0     /cdrw        auto     noauto,ro              0 0
    /dev/cdroms/cdrom1     /dvdrw       auto     noauto,ro              0 0
    #/dev/fd0              /floppy      auto     noauto                0 0
    
    none           /proc       proc     defaults                        0 0
    none           /dev/shm    tmpfs    nodev,nosuid,noexec             0 0
    PS- here is my /etc/fstab

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    Really -no ideas, anyone?

    thanks

    scot

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I don't know if this will help or not. When I looked at my /etc/fstab in Gentoo, there were some differences. You could try editing yours.
    Code:
    # <fs>                  <mountpoint>    <type>          <opts>
    <dump/pass>
    
    # NOTE&#58; If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda9               /boot           reiserfs        defaults,noatime
    1 0
    /dev/hda9               /               reiserfs        noatime
    0 1
    /dev/hda3               none            swap            sw
    0 0
    /dev/cdroms/cdrom0      /mnt/cdrom      auto            noauto,users
    0 0
    /dev/fd0                /mnt/floppy     auto            noauto
    0 0
    /dev/cdroms/cdrom1      /mnt/cdrom      auto            noauto,users
    0 0
    none                    /dev/shm        tmpfs           nodev,nosuid,noexec
    0 0
    
    # NOTE&#58; The next line is critical for boot!
    none                    /proc           proc            defaults
    0 0
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory &#40;shm_open, shm_unlink&#41;.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    you said random numbers on the screen ....but were they by chance
    Code:
    99 99 99 99 99 99 99 99 ect.....
    if so then you need to
    Code:
    /sbin/lilo
    if not could you please try to write the numbers down they might be lilo error codes
    also try to post here what that flurry of messages are or pertains to

    also dose it boot into windows? or into nothing
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    Thanks, loft.

    Actually- I don't really see numbers on the screen. It starts to show the
    usual boot information in the console window and is beginning to boot gentoo, but then the screen quickly
    changes to black with random dots on it and alternating bluish stripes. There
    is nothing legible on the screen when this happens.

    The boot messages disappear so quickly that I can't follow them either.
    So, the best I can do is look at /var/log/messages (or so I think) and
    find out what got written there.

    It will boot into windoze from the lilo prompt.

    Scot

  7. #6
    Just Joined!
    Join Date
    Oct 2004
    Posts
    13
    Scot, where's your boot partition? I don't see one. I see a root, a swap, and a bunch of others, but no boot. Sounds like something video related though - maybe during cold/hotplugging. Did you install either/both of those? Have you set it up to go straight into X/K/Gnome? Maybe it's dying on the video setup going into X.

  8. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    Quote Originally Posted by gentoo409
    Scot, where's your boot partition? I don't see one. I see a root, a swap, and a bunch of others, but no boot. Sounds like something video related though - maybe during cold/hotplugging. Did you install either/both of those? Have you set it up to go straight into X/K/Gnome? Maybe it's dying on the video setup going into X.
    1) I don't have a boot partition. /boot lives on / (/dev/hde2). This caused
    me some trouble (I think) getting grub to work, but lilo, I believe, handles this
    fine. (It's what I've always done, but I think I'll do a real /boot partition next time.

    2) I did install X during the install process - otherwise I did everything
    according to the installation guide. I'll check about turning X off, but it looks
    too early in the boot stage for X to be the problem. (Remember, the last
    thing in /var/log/messages is always the hde* partition mounting.)

    Thanks,

    scot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •