Find the answer to your Linux question:
Results 1 to 6 of 6
I just installed gentoo 2005 but when i boot, it gives me this error message: SIOCSIFNETMASK: No such device *ERROR: Problem starting needed services. * "netmount" was not started. What ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89

    problem booting gentoo after intallation


    I just installed gentoo 2005 but when i boot, it gives me this error message:

    SIOCSIFNETMASK: No such device

    *ERROR: Problem starting needed services.
    * "netmount" was not started.


    What is wrong?

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Netmount don't start if there's some problem with the network... if you use DHCP, you must have installed dhcpcd, edited /etc/conf.d/net to be like this:
    Code:
    iface_eth0="dhcp"
    dhcpcd_eth0="-HDN"
    And most importent of all, remember to compile the kernel-driver for your network-card, preferrably compile it into the kernel (not like a module)

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    I am using static ip, i already tried "dhcp", it dosent work. How do you compile the kernel-driver for your network-card?

    Also, when i boot up and get the error mesage, i try to type "ifconfig eth0 up", but it says this: "eth0: unknown interface: No such device". Is it not detecting my ethernet card?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    In your case it's not detecting the ethernet-card, I had a lot of issues with that me too... You compile the kernel driver by recompiling the kernel:
    Code:
    cd /usr/src/linux
    make menuconfig && make && make modules_install
    And then you either copy the kernel over manually, or type "make install" (if the latter one, make sure lilo/grub points to /boot/vmlinuz). How to manually copy over the kernel can be found in the gentoo-documantation. Also remember to save your kernel-configuration after changing it . Also notice that you will have to re-run /sbin/lilo after installing a new kernel or changing lilo.conf.

    The ethernet-drivers can be found here:
    Device Drivers --> Networking Support --> Ethernet (10 or 100 MBit)
    There select your card (assuming you are on 10/100 MBit ethernet, if not go to another section in the "Networking Support" section in the kernel-config.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    89
    ok, it did all that, but it still gives me the same error message.

    "cant start netmount", eth0: no such device.

    I dont know what i did wrong, but it still wont work.

  7. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I had a hell of a time with this issue as well. I eventually figured it out; however, it would have gone much smoother had I emerged and used genkernel in order to compile my kernel, this will ensure that your network device will work, as long as it worked without a hitch using the installation cd. Gentoo genkernel also has a manuall configuration just like make menuconfig, so that you can see exactly how genkernel got it to work, and then you can compile your own kernel, which will make bootup much faster as well as kernel compilation in the future.

    Hope you figure this out soon
    Operating System: GNU Emacs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •